Cannot start LO with --disable-gui build

I’m trying to build LO 6.1.6 (gcc 4.9 armv7hl) with no GUI. I need LO functionality of parsing different files (including text, tables and presentations) and rendering it to png. So, I’ve configured build

./ --without-help --without-myspell-dicts --disable-gtk3 --disable-gtk --disable-gui --disable-kde4 --disable-dbus --without-doxygen --disable-report-builder --disable-coinmp --disable-odk --disable-cups --disable-lotuswordpro  --without-java --without-krb5 --disable-scripting-beanshell --disable-scripting-javascript --disable-sdremote --disable-postgresql-sdbc --without-fonts --with-parallelism=4 --with-system-boost --with-system-nss --disable-firebird-sdbc --with-system-hunspell --with-system-libatomic_ops --with-system-librevenge --with-system-epoxy --with-system-libmwaw --with-system-icu --with-system-graphite --with-system-harfbuzz --with-system-libpng --with-system-cairo --with-galleries=no --enable-cairo-canvas --with-system-zlib --without-junit

then make it, but when I’m trying to run ./soffice.bin --convert-to pdf test.doc or use lok::lok_cpp_init from LibreOfficeKit, an error occures:

LibreOffice - dialog ‘LibreOfficeDev 6.1 - Fatal Error’: 'The application cannot be started.

Little debugging through code gave me a clue, that it’s might be unability to initialize UNO or just setting wrong PATH\LD_LIBRARY_PATH\etc.

So, what am I doing wrong? (except using --disable-gui, I’ve seen, it’s experimental)