cannot unprotect calc sheet

I created a protected calc workbook with a password. I followed directions in the getting started manual. As a test I tried to remove the password protect by following the directions to 1 open protected calc save as and 3. uncheck (password) box. I have tried that and I cannot get the workbook unprotected. I have also tried throught the tools dropdown and uncheck the box but then it greys out the OK button and nothing is available.

You haven’t mentioned the version of LibreOffice, and the file format. I suspect tdf#133771.

I have the same problem. [LO v7.0.0.3 (x64)]

The spreadsheet was originally an Excel spreadsheet (.xlsx), with password.

If I open in LibreOffice and save as .ods and re-open in LibreOffice and was, as expected, prompted for the same password as was used in the .xlxs.

However, when I [Save As] I see that the [Save with password] checkbox is unchecked. If I save with the checkbox unchecked, the resulting file is still password protected. If I check the box, I am prompted to [Set password].

It is as if the [Save As] function does not know that the file is already password protected.

If I [Save As] Excel (.xls), then, if I try to open in Excel (2019), then I am prompted for password (as expected), but then Excel rejects the (correct) password and suggests I check [Caps Lock].

If I [Save As] Excel (.xlsx), then I get an error message:
Error saving the document name:
Write error.
The file could not be written.

How to strip out password? How to Save As .xlsx?

The only known workaround currently is to use version 6.4.