cannot update/refresh existing writer document to template style changes

I’m having the same problem as this fellow (Can not update existing writer document to template style changes):

I made changes to the template I was
using as the Writer default template
expecting old documents based on that
template to ask to be updated to the
revised default template whenever I
opened them because this had happened
before, but that did not happen this
time when I opened the old document.

The expected behavior is (quoting the description from a fellow here

  1. Create a new file from MY template
  2. Save and close it
  3. Open the Template
  4. Modify something
  5. Save it as the same template (overwrite)
  6. Open the document saved before
  7. LO will ask you if to update from the new template or not

Ironically, some people find the expected behavior hard to disable, for example (Don't update style from template):

I have a lot of templates and I from
time to time update them, but I don’t
want to update documents created from
them. Is is possible to disable the
window asking whether I want to update
the document? It is really annoying
because it pops up every time when I
open it.

Aparrently, there are preconditions to make it work, as @mikekaganski mentioned here: Can I continuously auto update styles from a template document? ; and explained here: Synchronize style sheets across documents - #5 by mikekaganski
I did the way that he suggests, but it still doesn’t work.

Am I doing something wrong? Is it a bug? Did anyone experience something like that? I didn’t find this problem on the bugs site.

Please help.

The system and LO are in Portuguese. Version: (x64) ID de compilação: 5d19a1bfa650b796764388cd8b33a5af1f5baa1b Threads da CPU:4; SO:Windows 10.0; Realizador da interface: padrão; Local: pt-BR (pt_BR); Calc: group threaded

EDIT: after hours of testing I found that it was something specific about the template. I replicated that template (by Loading styles) on a new one, and it worked fine. But, I think, this was only possible after reseting extensions (I’m not 100% sure about this).

I did the way that he suggests

Please be more specific on what did you do. Especially, if you have followed the part that tells

LibreOffice recognizes templates that are located in any folder from the following list: