Can't add image field from subform?

I have a primary table which I have built a form around. I also have two images associated with each record; I used the create form wizard to add one of the sets of images as a subform. These images display properly. I also have a number of other text subforms as one-to-one relations that I was able to add successfully manually by creating additional subforms, joining properly in the form navigator and dragging the appropriate field(s) from the add field dialog.

If I follow this same approach with my other image table, though, I can add the integer index of the image but not the image itself. The field shows up in “Add field” but when I drag and attempt to drop it onto the form page, it does nothing.


Have no problem with separate images in different tables.

Have attached a Firebird embedded database as a sample ---- images2.odb

Did not spend a lot of time with this. Just proof of concept. Needs more.


Sorry for deletion. Wanted to insure one to one relations. Still needs more attention but works. Manual construction for second sub form.

Just a note.

Also tested in PostgreSQL and worked there as well.


Used Binary[bytea] in PostgreSQL table definition for images.

I am using a PostgreSQL database and the bytea data type. I just now created a new form with the main form referring to my primary table and added a subform with Content Type Table and Content being the table with the images. I joined on the appropriate field and when I select this subform in the Form Navigator I see the two fields in the image table but when I try to drag the image field, nothing happens.

I tried this as just a minimal example to add a single image field and I can’t seem to get it to work properly. In the main post when I mentioned I had a single image appearing that was the case but I was relying on the form wizard which detected the relation as the two tables have the same field, id.

I tried recreating the form you have in this test database and I was able to copy the image fields from subforms successfully. So it might be specific to using PostgreSQL or at least an external database?

@brcopeland stated:

So it might be specific to using PostgreSQL or at least an external database?

No. If you re-read my comment above you see I did this in PostgreSQL also without a problem.

How are you creating the relationships? Through Base on Relationship screen? Dragging from Master to image?

I did see your comment; it was just my experience here that the method I followed worked for an embedded database and did not when connecting to PostgreSQL.
So what I have done is:

  1. Create a Form from my primary table
  2. In Form Navigator, right click on the form, and select New->Form
  3. In Form Navigator, right click on the subform, and select Properties
  4. In the Data tab, select the images table in Content
  5. In the Data tab, set Link master fields & Link slave fields to "id"
  6. In Add Field, attempt to drag the image field onto the page


Very sorry as until now did not recognize you were in the design phase of a form. Thought you had that done and were having problems with adding data (picture).

I very seldom use the tool to add fields. Instead I use the actual controls from the Form Controls toolbar. There is an image control there you can select. Also available from the menu - Form->Image Control.

My supposition that the Add Field has a bug and does not recognize the Binary[bytea] type and therefore does not know what control to insert.

Thanks again @Ratslinger, you’ve been very helpful. I think you’re right that there’s a bug with the Add Field menu. I wasn’t previously familiar with Image Control but using that I was able to get this working properly.