Can't add Java Runtime Environment

I’ve combed through several posts related to this one, but I have not found a solution.

I discovered that Libre can’t find java on my system when I got the following message:
“LibreOffice requires a Java runtime environment (JRE) to perform this task. Please install a JRE and restart LibreOffice.”

System info:
Running Libre Version:
Mac OS: 10.11.6
Oracle Java version 8.111

Attempting to solve this, I updated Oracle Java to version 8 update 111. And installed Apple’s legacy Java 6. I then saw in some other posts that a JDK may be needed, rather than a JRE. According to Oracle’s website, I need to download a file called jdk-8uversion-macosx-x64.dmg, which I have been unable to find. I believe that the installer in jdk-8u112-macosx-x64.dmg should also install a JDK, however. But it seems not to have. I am at a loss.

In Libre, I went to Settings/LibreOffice/Advanced and verified that “Use a Java Runtime Environment” is checked.
I then clicked the “Add” button, which prompted me to browse my system for a runtime file.

I browsed the following directories, without finding a file that Libre would accept.

I’m guessing that I didn’t actually install a jdk because the following directory does not exist.

What do I need to do?

Sad no-one’s even responded to your q.: I’ve the same problem, hence being here. A response to a related q. asserted that JDK*, not JRE, is a fix. Ratslinger (K11,905) said JDK is huge & RAM-hungry so (Open)/JRE is OK. I’ve d/loaded several JREs, deleted older ones, found ‘your’ dialog to Add it, selected the folder and get your error msg. ANOTHER q. had a screenshot with the equiv. folder as a sample! If LO won’t find it, I can’t add it, so can’t run a database.
Help, anyone?

  • contains JRE

Yep. I had Java installed for weeks, and it showed up in Tools - Options - Advanced as it should. A few days ago Java no longer showed up, and the checkbox “Use a Java runtime environment” would not stay checked. I check the box, find Java via the “Add” button, and make sure the radio button is selected. But as soon as I open the dialog again, the box is unchecked, and nothing shows up in the list below, even if I wait. x64 Windows 10, Java 64-bit, LO 64-bit. Frustrating.

General info on installing Java is available on the LO wiki here:

FAQ | General | Install Java

Specific help from the same source for those using Macs is here:

Using macOS

“On macOS 10.10 and newer, please note that you need to install JDK, not JRE”

(links to downloads also provided)