Can't Connect to Access Database

I’m using Windows 10 (64-bit) and when I try to connect to an Access database, I get

“The connection could not be created. May be the necessary data provider is not installed.”

Windows 10 doesn’t use ODBC so how can I connect to Access? I’m using LO (x64)

Suggest you get ODBC datasource (connectors) defined as @peterwt has pointed you to below. Then test using Access: create link, select type (at bottom of file window that opens) of ODBC (it’s way at the bottom of the list, at the bottom of the screen), then select your newly created ODBC datasource and the table to link to and test it out. That will work you thru the ODBC maze so you can see how it works. Then once you have this working, try to use LO with an ODBC datasource.


Please search this forum for an answer, as this issue is not a new one. For example, here is one such finding that might answer your question that I noticed when I entered Access into the search box above.

Then if you get stuck again, feel free to come back here and ask about that specific issue.

ODBC is in Windows 10 - see here

@peterwt, Have you actually tried ODBC lately? I tried it some time ago from Linux and I ran into a bug that I reported and was confirmed and to my knowledge has never been fixed. I have been assuming it does not work. ??

@EasyTrieve I was pointing out that ODBC is in Windows 10 as the poster said “Windows 10 doesn’t use ODBC”.

@peterwt, ok. I see. Also your link above doesn’t work for me (is broken).

@EasyTrieve Updated link.

@peterwt I got ‘The specified DSN contains an architecture mismatch between the driver and application’. LO is 64-bit whereas the driver is 32-bit (no 64-bit ODBC driver - by default). For this you need this package.