Can't delete a base report

I have two HSQL databases which share the same relationship model.

So I create the reports in one database, and then I copy them in the others and they work the same.

On one report, however, I realised I wanted to modify it. So I modified it in the first database.

When I want to delete the bad report from the second database, I can’t! Seems like a bug to me. Have you heard of that, how can I solve my problem?



Do not know if this will rectify the problem but dealt with a similar situation with a form → Cannot delete a form in Base

Other than this process or you posting the Base file, I have no other solution.

db.odb (221.7 KB)
Here I attach the database.
I removed all personal information (basically, all the tables).
The behaviour is still present.
I cannot delete the following reports that I want to delete :

I tried to unzip the file to see if I could delete the reference directly from the xml but when I zipped back to odb, base told me it was corrupted.

If you reach to a solution, please tell me how you do it!



It appears the reports are missing from the Reports folder but there are still entries in the content.xml file of the root directory.

Edit this file and remove:

<db:component db:name="rNOOOtesDeFraisKilometriquesAnneeXXX" xlink:href="reports/Obj141" xlink:type="simple" db:as-template="false"/>


<db:component db:name="rNotesDeFraisKilometriquesAnnee" xlink:href="reports/Obj131" xlink:type="simple" db:as-template="false"/>

Save the file and all should be OK.

It is the process I tried but the file was corrupted because I was zipping the whole folder instead of zipping the files in the folder.
But it works.
But still there is probably a bug which caused this situation.

Can’t say yes or no to this. In many years of using Base I have not had this happen. Have certainly created my own problems.

You can report as a bug (Bugzilla) but will need to be able to reproduce the problem. That is likely not probable.

Thank you very much.

I filed the bug there :