Can't delete records

The only way I can delete a record is to open the Base-File, load the table and use the menu “delete record”.
All other ways I have tested did not work. The buttons on the bars I use to manage records are always inactive.
I think it is be a bug but couldn’t find any helpful support.

Libreoffice 6.0.3. Linux-mint 19.1 cinnamon MySQL Connector 1.0.2 MariaDB on a Synology Disk Station

Edit 2019-05-18 from not an answer answer (by @Ratslinger):

I’ll give you one simple example:

You sea a tablecontrolfield in a form with one simple table. The navigation bar is added in the same form.

The bottom to delete a record is never acitve. But for the from, the permission is given.
When I open the base-file, there is a menu to delete a record an it is active.

I used the same form with Ooo and Windows an I never had this problem.


All other ways I have tested did not work.

What all do you have testet? Discribe any examples.

Have you tried a different connector such as JDBC or ODBC?

Not yet. I’ll try.
My intention was migration of all my large Ooo forms and all my basic codex files from windows to linux. I fear, I have to change a lot when I use a different connector.


Seems to be a bug and should be reported here → Bugzilla.

Have tested using Mint 18.3 with LO v6.2.3.2, MySQL and SDBC connector and have same result. Using a JDBC connector there was no problem.

Edit: ODBC connector was also OK.

Thanks a lot. I’ll report the bug.

I reported it on Bugzilla.

Must have been a bug of Synology DS, that resisted a long time even I had all updated.
In the last few days I got a new update of MariaDB (5.5.62-0091) and now it works properly.

I’m running into this problem right now on 7.3 as packaged with *buntu 20.04, using a purely local database (no remote database being connected to, it’s all within the .odb file). So maybe the bug was (and maybe still is) somewhere else . . .

Sounds like a different issue. Please post as a new question an include details of LO version, database used and OS.