Can't download LibreOffice4 .exe file

Hi! I read in another post that if you click the link “Main Install” link on the download button, you get .exe file. Well, I’m an American studying in France. It sends me to a mirror site and it tries to download a .man file, which I don’t want because I don’t get involved in torrents. I expect .exe file.

I’ve been a LibreOffice user for a long time and tomorrow, I have a presentation due. I got a new notebook computer and wanted to install LibreOffice on it.

You are doing a HUGE disservice by not offering the .exe file. I have wasted more than hour waiting for the download, discovering that my computer can not open a .man file, that I might have to install a bit torrent program to re-install the .man file and blah blah blah.

Guess what? YOU SUCK!!!

I am switching to OpenOfficeOrg because the day I have to spend TWO HOURS trying to install a program is the day I throw in the towel.

Today has a arrived!

Fix your software downloads on all your mirror sites or be prepared to lose more end-users. Not all of us - even software engineers - want to hassle with complicated downloads. Some of us have very fast broadband connections and downloading .exe files isn’t a problem. Chew on that while I jump from your sinking ship to one that’s user-friendly and not catering solely to the amateur tech community with too much time on their hands.

Please Sally, take it easy.

In official download page:

Clicking on Main Installer, link to:

Downloading the file:
.msi are files created to be run with the Windows installer.

And here you can find all versions for all systems:

The domain is consistently down. That is a problem (see my remarks below)…
Unable to connect
can’t establish a connection to the server at
The site could be temporarily unavailable …

Sorry @dpell, but I haven’t problems with any of this sites. Maybe they are blocked by the browser. Have you tried with a different browser?

Don’t download so ancient LO, stick to very newest. Have this priority:

  1. Newest RC version for Fresh branch.

  2. If there’s no RC version for Fresh branch, check French branch itself.

  3. If there’s no version available for Fresh branch, check RC versions for Still branch.

  4. If there’s no RC version for Still branch, take the newest Still version.


This has been covered in another part of the forum.
I believe it may be due to a bug in IE. The .msi file is always saved as a .man regardless of what you do.

You simply need to rename the downloaded .man to .msi and voila - it starts the install.

So, this frustration (and subsequent rudeness) is one side effect on one’s health of using IE :slight_smile:

See also:

I completely understand your frustration, but being rude to the volunteers will not get you any closer to solution. So being polite does not cost you anything.

I have never heard of .man file type, maybe you got corrupted download. Maybe downloaded with some download accelerator or something…

If you can’t download from official LibreOffice web page there are plenty of other non-official web pages to download from. I like just enter LibreOffice in search box and you get to download page. Very useful web page for all sort of software downloads.

With all respect, I have to echo Sally’s frustration. After talking up the virtues of Libreoffice (I run it under Ubuntu),I attempted to install it on my girlfriend’s Win 7 machine. It just doesn’t work. I can’t get a clean, non-broken download. I’ve never had this kind of difficulty trying to install software.

How do you know you don’t get non-broken download? Did you create a checksum? Did you try to execute .exe file? Did you get any error? One other way to download LibreOffice is using torrent. On Windows download micro-torrent program from: install this program and then from download torrent file and open it with micro-torrent program. It will start downloading the file. I always download this way and it always works without a problem.

I also was frustrated with the .msi download. I cuoldn’t install on Win 7, wouldn’t recognize the file. Other .msi have worked since. spent abt 2 days on the problem. But for me, was a problem with Win installer. Been using Android apps on my tablet for that purpose. Yes, frustrating. (but, that means I can work in, in that respect it is a win, but I wanedt Libreoffice back on my desktop. I think it worked this time since they updated and used the torrent instead of .exe. go figure!

I have the same problem. I have windows 8 and when trying to download the msi the download file says .man I have tried this several times with the same result. Had to get from another site in the end. Download says its coming from

Both “download” and “downloadarchive” prefixes are Not working.

The donate page redirects you to (vers 4.1.1) which just dies (with any browser – Firefox, Chrome, etc).

The domain web prefixes mentioned above seem to be broken.

(My previous post here:
Download prefix broken -- -- No longer works)

I usually don’t trust those alternative download sites like hippo, etc.

I ended up going to the, right-clicking and copying the Info hyperlink under the Main Installer (to get the official mirror list), and then googled it to obtain a cached web copy listing the appropriate mirrors (actually clicking the Info link would not work since it tries to refer you to, for instance). (To get a cached copy of any page from Google, do your search, then click the down arrow just to the right of the desired link and select ‘Cached’ [see]). This produced a page with clickable download links for the installers [].

So for 4.1.1, I ended up searching on:

And here, I just guessed that the mirrorlist address would follow the same naming convention (there is no Info link for the sdk):

Donete page links me to download:
no sdk in the link, and download fine for me with firefox.

Interesting. You’re being redirected to a mirror site from the get go, instead of the main download page. I’m consistently sent to the main.

BTW, these domain prefixes have been broken for months judging from the posts I’ve seen (I couldn’t find an email address to forward this issue to).

The sdk reference is for the developer toolkit

So… Here I am again experiencing the same issue with your server. This time trying to download for my linux system. The issue seems to be that your main hosting site – Index of /libreoffice – which is consistently down at least 80% of the time when I need to download it. Unable to connect: Firefox can’t establish a connection to the server at Please fix your server issues…! I’m thinking FreeOffice or KingOffice now.