Can't enter apostrophe in calc for text formatting

I’m used to formatting some values like date as text by inserting a leading apostrophe. E.g. entering 'April 2016 if I want the cell to render the text April 2016 instead of some default date format like 04/01/16

Since some recent update of version 5.X I can no longer enter the apostrophe. When I type the key a “lower” single quote gets inserted (this is not a comma!).

I’m using the german localiced version (LibreOffice 10m0(Build:2)) with a german keyboard on a german localized Kubuntu 14.04.4 (Qt: 4.8.6, KDE: 4.13.3). This is driving me crazy. Can someone help me how to fix this issue?


PS: other programs are not affected by this. I can e.g. enter the apostrophe in kate and copy that over to calc and let '2 be rendered as the text 2 (not the number)

It sounds to me like an autocorrection effect for the typographically correct way to quote words in German. I cannot reproduce it here because I use a different locale, but I get such auto corrections when I type a text in my own language.

You can toggle auto correction through ToolsSpelling autocorrect. This will disable ALL auto corrections, but they can be re-enabled with the same command.

If you prefer to be more specific, go to ToolsAutoCorrect options, tab Language options and play with the settings, but be warned that your new settings will be in effect for all Office components: Writer, Calc, Draw, Impress. Consequently, you’ll lose the standard auto correction also in Writer. Pierre-Yves Samin recently advised against these language options modifications which are intended to give typographically (and grammatically) correct results in your local language.

You’ll then be better off with temporary toggling.

If this answers your question, don’t forget to tick the suggestion for community benefit.

EDIT: answer corrected as per OP remark about Shift+F7

You, sir, are a genius. It was the locale dependent autocorrection option for single quotes. I deactivated it (as single quotes are rarely used in german, compared to double quotes) and it is working! Too stupid that this feature of LO/Excel (format number as text) interferes with the autocorrection. BTW. this cannot be toggled with Shift+F7 as this only toggles automatic spell checking, but not the local dependent autocorrections.