Can't find program after install Linux

I have tried multiple things. I have been using LO for many years. I upgraded to 7.042 without issue. I then upgraded recently to 7.112 and have been having issues with the dictionary functions where nothing shows on the dialogue boxes when spell check is opened. SO I tried to reinstall 7.042 after deleting all the icons off the computer and applications popup. I completely uninstalled all the LO files from synaptic package manager eventually and reinstalled the 7.042 package but cannot find it anywhere except in “Software” package option where only writer is now listed.

Is there a way to clean up the system so I can reinstall as if it were never there before with all files and references removed?

Your question can’t be answered without your distro name. I assume from the mention of synaptic that it is some derivative of Debian. Removal of an application should be done with the package manager to be certain that all files are erased. Deleting icons is not safe.

Please do not use Add Answer but edit your original question to enhance the details of your question (answers are reserved for solutions to a problem on this Q&A site).

I have this on Linux Kubuntu 18:04 LTS

Use apt-get. The most reliable way to install applications is through the distro repository. They are not bleeding edge but they have been tested for compatibility by the distro maintainers. may not have already bubbled up in the repos but 7.0.4.x and 7.0.5.x are considered as mature and stable.

What I would do is to remove all the LO packages that would still be listed in Synaptic. Then download LO from the download page (Download LibreOffice | LibreOffice - Free Office Suite - Based on OpenOffice - Compatible with Microsoft) and install it with dpkg.

Extract the archive (tarball) then follow the command lines in Installing LibreOffice on Linux - The Document Foundation Wiki (adapt the version number or just start the command line and hit Tab key to autocomplete)

cd LibreOffice_$version_Linux_x86-deb/


cd DEBS/


sudo dpkg -i *.deb

Et voilà.

What I would do is to remove all the LO packages that would still be listed in Synaptic.

… plus:

  • sudo apt autoremove (esp. important if switching as per answer to another repository)
  • rm -r $HOME/.config/libreoffice/* (OP asked for …as if it were never there before with all files and references removed)

Did this several times.
I finally found the executable files and added the listings to the applications menu and was able to put icons on the desktop from there and they work. I am now happy again since I use the writer every day.
I do not know yet if the auto text and correct options are working correctly but will check on those.
THANKS for the help

Have you installed the packages from the LO website? The point is to have the latest version, be it still or fresh (7.0[.5] being advised IMHO).

I would keep the former user profile so that any former customization could be retrieved (like autotexts, custom dictionaries, extensions…).

Please click the gray checkmark left of the answer to show your question has been solved so that other users can refer to this one in case of need.

sudo apt-get install libreoffice