Can't get Offline Help to Work with Firefox

I have used LO full time for the past several years, albeit without the use of off-line Help. After finally getting around to install the Off-Line Help, I now can’t get it to work.

  • OS: Ubuntu 22.04 LTS x86_64
  • LibreOffice v. manually installed and upgraded from .deb
  • Installation directory: /opt/libreoffice7.3
  • Default Browser: Firefox 99.0.1 (64-bit)


Help won’t work with Firefox as my default browser. Changing the default to Vivaldi 5.2, the Off-line Help appears to function as I would expect. How do I make Off-line Help work with Firefox as my default browser.


Installing the Help Pack:

  • Downloaded the Help Pack: LibreOffice_7.3.2_Linux_x86-64_deb_helppack_en-US.tar.gz
  • Extracted the file
  • Ran GDebi Package Installer to install libobasis7.3-en-us-help_7.3.2.2-2_amd64.deb
  • The installation procedure appeared to run fine and it installed in /opt/libreoffice7.3/help directory

When I hit F1 in Calc, Firefox opens and it says: “Firefox can’t find the file at /tmp/lu15648351xi731.tmp/NewHelp8.html”

When viewing in a text editor, the NewHelp*.html files appear to have the correct links to the program and Help files, they just won’t open in my browser.

Navigating to the: NewHelp*.html files in /tmp/lu15648351xi731.tmp/ directory and attempting to open manually in various browsers:

  • Firefox: Get the same error “Firefox can’t find the file at /tmp/lu15648351xi731.tmp/NewHelp8.html”
  • Chromium: “Your file couldn’t be accessed”
  • Vivaldi: the files open to the appropriate LO app Help topic and all seems to work properly. When I click on various topics, they open the appropriate Help topic files that are located in the /opt/libreoffice7.3/help directory.

I don’t want to change my default browser from Firefox. What do I need to do?

For full functionality you have to use the LibreOffice version shipped with your Ubuntu. Firefox not finding some file in the /tmp/ directory indicates that Firefox is installed from a flatpak package. These packages can not see the /tmp directory. I think, this can be configured somehow. For me flatpak is the reason why I drop Ubuntu after 10 years.

Of course. Firefox and Chromium on my machine are both installed as Snaps, whereas Vivaldi is installed as a .DEB. Thus Vivaldi can see the /TMP directory. I’ve installed LO 7.3 from a .DEB as the Ubuntu version is only 7.2.

I’ve not had issues with the FF Snap as after the initial opening it runs fine.

So, I’ll have to make a decision …


LibreOffice seems to default to online help. This can be a bit annoying for anyone with limited download entitlement. If Internet is turned off, the default browser gets what is offline in /Libreoffice/Help, resulting in another annoyance; the insistence that the version of LO and version of Help must match. I would like to use LO version US but Language/Help version GB because yeah, we use dollars etc but spellings differ. The only solution I have found is to install both languages, and rename the …/Help/en-US/ directory, eg to zen-US. Apologies for bumping an older topic; first time for years using LO Ask.

No. It defaults to locally installed help, and when it doesn’t find one, it asks if you want to see the help on Internet. You may disable the prompt, of course, so next time when it doesn’t find local help, it shown content from Internet without prompts.


No, as explained above, your sequence (“If Internet is turned off, then it shows offline content”) is wrong.

Indeed, the UI used in LibreOffice, and the language of help, must match, as explained in FAQ.

However, the problem mentioned here by @Singlespeed initially, was likely tdf#148633 about Snap-packaged browser.