Can't install 4.4.4 on Win8.1 64bit - How do I make sure it downloads the right file and size?

I am downloading off the download page. I don’t know if I’m getting some kind of cached copy or what, but I keep getting this error:

“This installation package could not be opened. Contact the application vendor to verify that this is a valid Windows Installer package.”

I have a new R7, using Windows 8.1, 64 bit, haven’t yet had any problems downloading any other programs. I tried creating a registry entry to allow me to run the install program as administrator. I tried turning off all smartscreen/windows defender options. Still getting the same error. I tried running the portable version and am getting the same error. I’m trying to download 4.3.7 but it’s taking an unbelievably long time to download.

I can’t open my documents and I really, really need Libre to work. Any suggestions?

I noticed the files being downloaded are not at all the right file size, but I don’t know how to fix it.
Please help me.

Eventually I downloaded from different mirrors, instead of off the page and voila! Finally it worked, but not with 4.4.4. I was able to install 4.3.7 so that’s what I’ll be using for the next week. 4.4.4 didn’t download properly even using different mirrors.

Your OS is telling you that the MSI is corrupted + 4.3.7 is “taking an unbelievably long time to download”? That sounds like a system problem to me. Nevertheless…

You need to check first that your download matches the file on the server. You need to do 3 things:

  1. Download md5sum.exe
  2. Find the MD5 for your download
  3. Check the md5 on disk to the md5 on the server

md5sum: This available for every Linux system, but for Windows you will need to download it. I have zero connection with & neither can I guarantee the efficacy of that file; use at your own discretion (see also bottom).

MD5 Hash: This is the LO Download page. You need the “info” link to see all the various checksums, which is normally underneath the big ‘Download’ button (you are looking for the “MD5 Hash” checksum). I cannot get to the Windows-x64 page no matter how hard I try (my system is x86) so I cannot advise you what the md5 will be.

Check md5 hash for download to server: That needs to be done from command line, which may cause you all sorts of faffing about under win8.1. Here’s an example from my own system (Debian 6.0):

:~$ md5sum readme.txt
fcc3a59dd18df51e370b401f5018f60e  readme.txt
:~$ md5sum -b readme.txt
fcc3a59dd18df51e370b401f5018f60e *readme.txt

I’ve done it twice so that you can see the difference in the output between the default text mode (1st line) & binary (’-b’, 2nd) mode. These modes are identical under Windows, so md5sum.exe output is always in binary format. ‘fcc3a59dd18df51e370b401f5018f60e’ is the actual md5 for that file, and the kind of string of hexadecimal nonsense that you will use to check the integrity of your download.

For completion, here is the help output from the program:-

:~$ md5sum --help
Usage: md5sum [OPTION]... [FILE]...
Print or check MD5 (128-bit) checksums.
With no FILE, or when FILE is -, read standard input.

  -b, --binary            read in binary mode
  -c, --check             read MD5 sums from the FILEs and check them
  -t, --text              read in text mode (default)

The following three options are useful only when verifying checksums:
      --quiet             don't print OK for each successfully verified file
      --status            don't output anything, status code shows success
  -w, --warn              warn about improperly formatted checksum lines

      --help     display this help and exit
      --version  output version information and exit

The sums are computed as described in RFC 1321.  When checking, the input
should be a former output of this program.  The default mode is to print
a line with checksum, a character indicating type (`*' for binary, ` ' for
text), and name for each FILE.

Report md5sum bugs to
GNU coreutils home page: <>
General help using GNU software: <>
For complete documentation, run: info coreutils 'md5sum invocation'

If this helps then please tick the answer (:heavy_check_mark:).