Can't install LibreOffice 5 on Windows 10

I upgraded my Lenovo laptop from Windows 7 to Windows 10.
I had LibreOffice 4.4.4 installed when I did the upgrade. I then tried to install LibreOffice 5.0.0 without success.
I then uninstalled LibreOffice 4.4.4.
In my Downloads folder there are right click options to Install / Repair / Uninstall the LibreOffice installation file.

However with other software programs with exe extensions I have downloaded, the options available are to Open or Run as Administrator.

It seems to me that msi files need to be setup in the same way as exe files in Windows 10?
Not sure of what I need to do here.

I am not sure that I understand your problem. Usually, LibreOffice 5.0 should just install.

You can make a clean install if you uninstall Lo 4.4.4 (I think you did this already, please check in the control center whether it is removed). Then you can delete (or rename) the user profile ( Then download the new version from the website. It should be an .msi file. This you should be able to simply install by double-clicking on it.

Thanks for the reply.

Problem now solved.
I posted the question in the Windows 10 forum with the same username and there is a file you can download to add “Run as administrator” to the right click options.

The link you need from the windows seven forum is in blue at the start of my post.

I also have this problem trying to install libreoffice on Windows 10.

It always says that is corrupted. Then the only option is to cancel the installation.

Tried with libreOffice 5.3.6 and 5.4.1.
Downloaded them several times.
Tried to run them as an administrator.

Any help will be welcome.

Given that you get that corruption notification, it might either mean that your downloader does poor job, or one of our mirrors is broken (or a combination of these). I suppose that our mirror picker would keep choosing the same mirror for you each time based on your data, so maybe choosing a mirror manually could help you.

See also here.

Thanks for your answer. I downloaded from another mirror and it worked fine.