Can't install LibreOffice 7.1.7

I am trying to install LibreOffice 7.1.7 on my new laptop. I have Windows 10 and am installing 64 bit version. I’ve had no problem installing or using it before. When I install it, it puts a shortcut on my desktop. It is in the start menu with all the components listed-writer, calc, etc. but LibreOffice won’t open. I have also had it repair the files after installing and that hasn’t helped either. I also downloaded the help file but can’t find it. I have uninstalled it and re-installed it twice and the same thing happens.

Hi. Have a read through of General Installation Issues (Windows).
Cheers, Al

1 Like

I have read General Installation Issue page. I do not get an error message. It looks like the installation is successful. Like I said, all the components are in my Start menu and shortcut on my desktop. I uninstalled 7.17, rebooted and tried installing 7.16. I went through the installation wizard choosing typical installation. No problems. Again, it was in my start menu with all components and shortcut was on desktop. I found location in Windows program files folder on C drive. Properties said size is 1.17 GB, size on disk 1.20 GB, Contains 25,274 Files, 1,033 Folders_ ‎Created Friday, ‎October ‎8, ‎2021, ‏‎12:47:11 AM, Attributes-read only checked. So why can’t I open it? I’ve tried opening from start menu. It looks like it spins for 1 sec. then nothing happens. Windows 10 is up to date. I only have Windows Defender on right now. Since I’m not getting error message, I have not turned it off. I will be installing ESET as I have license but haven’t yet. I’ve been using LibreOffice for years and have donated a lot of money to the Document foundation so am really confused by this. I have it installed on my desktop computer. Not sure about version. I could try backing it up on flash drive and installing that version on my laptop but think i will run into same problem, assuming that’s even possible. I’ve not had any problem downloading and using apps from Google play, printer software, etc.

So you installed LO 7.1.6 with Defender turned off as in General Installation Issues…?
And have Restarted Windows in case the installation needed to complete because other program might have been using the files.
What did Microsoft Troubleshooter report?