Can't install Mendeley plugin

Hi everyone,

Could anyone help me with the stupid problem: I can’t install the plugin cause I don’t have the option “Install LibreOffice plugin” in my Mendeley Desktop.
According to this instruction (https://community.mendeley.com/guides/using-citation-editor/01-installing-citation-plugin) I should see the option “Install LibreOffice Plugin”, but I have only the three: Invite Colleagues, Install Web Importer, Check for duplicates… and no more. Seems, my Mendeley don’t know that I have LibreOffice on my laptop. How to let them know about each other? I’m not sure, but on the basis of overall stability of LibreOffice I think that the problem connected to the software. Seems, Mendeley works well…
Both the software is up to date:
Mendeley Desktop 1.17.6
LibreOffice Vanilla Version: 5.2.3.5
macOS Sierra 10.12.2

Please, send me in proper direction (not to hell, please :slight_smile: with my attempts to fix the problem.

well, I solved the problem by installing MS Office. There was no any problem with Mendeley plugin installation once MS Word been installed.

Thank’s! )

problem solved as below:

  • open LibreOffice Writer
  • Choose Tools\Extension Manager\Add
  • Browse to: C:\Program Files (x86)\Mendeley Desktop\openOfficePlugin
  • Choose the plugin in the browsing folder and open
    Hope it helps

Thanks! this solved it for me!

I tried this solution and it did not work.
I still only have the MS Word plugin appearing under the web importer.
Any clues?

Worked for me as well - thanks

Thanks, it worked for me. LibreOffice 6.0.1.1 (x64), Mendeley Desktop 1.17.13.

Hi Xavier. I had the same problem like yours. I have been solved using the solution given by SamAus:
open LibreOffice Writer - Choose Tools\Extension Manager\Add - Browse to: C:\Program Files (x86)\Mendeley

I iadded the Mendeley extensions, and despite still only appearing in the Mendeley the MS Word plugin appearing, in the Libre Office I could insert references. Dont worry if does not appear LibreOffice in the Mendeley. The citation runs anyway…

I had this problem 'cause I used the Linux Mint App manager to install Mendeley.
Once I downloaded it directly from Mendeley website and installed through the Terminal, it worked properly.