Can't launch LibreOffice 4.4 on Linux Mint 17

Uninstalled LibreOffice 4.2 from a new install of Mint 17 Cinnamon, downloaded the LibreOffice 4.4 tar files and extracted them all into a folder on the desktop, then installed, as per the README, from a terminal window in that folder with

sudo dpkg -i *.deb

Now, its icons appear in the Cinnamon menu, but when I try to start any of them, I get

LibreOffice 4.4 - Fatal Error
The application cannot be started.
User application could not be completed.

What more information would be useful, and where do I go from here? TY.

I cannot say what went wrong with your installation. However @karolus gave me very valuable help, which you find here:

With his guidance I installed 4.3.5 on kubuntu 14.04, which has the same ubuntu version as MINT 17.

Note: I keep always the LibO version coming from the kubuntu repository installed as a fall back version should I run into a problem with a newer version. My intention is to install always 2 newer and additional version (currently 4.3.7 and 4.4.2) parallel to the repository version.

Not useful.


Try to rename your userprofile,

mv ~/.config/libreoffice/4/user/  ~/.config/libreoffice/4/user_old/ 

and start LO again.

Don’t work either? – start from Commandline:

/opt/libreoffice4.4/program/soffice --calc

and post full messages from Terminal.

Moving out the old profile solved it very nicely! TY!