Can't load fonts

I’m using LibOffice on Mint 18.1 64 bit and unable to get new fonts that I’ve added (e.g. Droid Serif) to load from /home/mydir/.fonts -or- from /usr/share/fonts directories

I’ve restarted LibreOffice

and even tried 2xclicking on the font and install from the dialog box without any luck

Build ID: 1:5.1.6~rc2-0ubuntu1~xenial1
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group

any tips tricks or am I missing something? any help appreciated :)

After the files are copied to your font directory you need to update your Linux font cache.

sudo fc-cache -f -v

Then they will be available in LibreOffice.

Please click the check mark at left if this solved your issue.


I’ve done the refresh from the command line twice and I still cannot access new fonts (eg, DroidSerif) from the pull down menu although the font does show up in Options/LibreOffice Writer/Basic Fonts

I reinstalled all the LibOff modules from Synaptic Package manager and the font I was trying to load now appears in the pull down menu and works in a doc but again new ones I try to install into ~/.fonts do not show up.

I tried doing sudo fc-cache -rfv in a term but that doesn’t work.

Checked permissions for files and dirs in both the ~/.fonts and /usr/share/fonts and everything looks fine.

Any other ideas are appreciated! :slight_smile:

I just found out through trial and error that new fonts installed into ~/.fonts DO NOT show up until you log out and back into your account. This is totally unacceptable behavior for an app. Is there a bug filed for this?!

Agree with @anechoic. This is not good UX… Still not solved in the version I am using (; build 1:6.0.7-0ubuntu0.18.04.10). :frowning:


$ fc-list | grep

I can see the new font that I installed.

I am wondering though if this is not reflecting a deeper problem though I know nothing of the internals… Can it be that the environment that we get when starting LibreOffice stays static throughout until restart instead of listening for changes to underlying data that should be caught and reflected in the environment? At least, there should be some functionality to refresh the font list from the fonts cache.

BTW, any issue tracker on this yet?