Can't open documents with LibreOffice

For the last few days I haven’t been able to use LibreOffice as it won’t open when I click on files I want to edit. I have tried various things to fix it. I now get a message saying "The requested operation requires elevation. I’m almost at the point of giving up but I am enjoying using Libreoffice and don’t want to have to change. Thanks in advance for help.

See "the requested operation requires elevation"? - #12 by peterwt for a solution.

1 Like

Thanks for this link. I have tried it but it doesn’t fix the problem. If I open LO from the apps list in windows I can then go to Open, find the file and it opens, but if I click on the file itself I get “The requested operation requires elevation”.

Any other ideas? Thanks.

As a workaround, on Windows you can open LibreOffice, then drag and drop files from the file explorer into the LibreOffice title bar (you will see a plus sign).

That is a very dismissive reply. The accepted answer in the link provided by @floris_v has two potential solutions, the first being the Windows permissions issue. It is most likely to be a Windows User problem, possibly due to a partially failed Windows Update. But maybe, you didn’t understand the steps?
Here are the steps from another site for the same issue:

  1. Log out of your user account.
  2. Log into the administrator account.
  3. On your keyboard, press Windows Key+E. Doing so will launch File Explorer.
  4. On the left-pane menu, click This PC.
  5. Now, go to the right pane and right-click your hard drive.
  6. Select Properties from the context menu.
  7. Once the Properties window shows up, go to the Security tab.
  8. Click the Advanced button.
  9. On the Advanced Security Settings window, click the Owner tab.
  10. Click the Edit button.
  11. Select the user you wish to set as the owner of the drive.
  12. Make sure that the ‘Replace owner on subcontainers and objects’ option is selected.
  13. Save the changes you made by clicking Apply and OK.

If, after having corrected the Windows User permissions, there is still an issue the suggestion was to try renaming your LibreOffice user profile. You can instead in LibreOffice, try Help > Restart in Safe Mode > Continue in Safe Mode to see if opening files works without accessing your LO user profile.

I’m sorry you felt my comment was dismissive. That wasn’t my intention. I have followed the steps in your comment. When I get to step 9 there is no owner tab but there is an owner with “change” next to it. It said “trustedinstaller” and I changed it to my user (I am an administrator).

When I had done that I am still getting the same error message "The requested operation requires elevation. I have also renamed the user profile and I still have the same problem.

If I go to my documents and click a file I get the error message. When I open Libreoffice (normal) Windows asks me, Do you want this programme to make changes to this device" and if I click “Yes” it opens the programme. If I then click “Open File” and navigate to the file I want it will successfully open it. But if I go to the file without first opening Libreoffice then I get the error message.

Thanks for your help. Any ideas from here?

It sounds like a Windows User issue. Maybe this advice from TomsHardware could help if the blobking programme is malicious software removal tool Windows Malicious Software Removal Tool keeps popping up | Tom's Hardware Forum