Can't open LibreOffice Word file: get message file format error found at 6520,7. How can I salvage this document please?

I was working on the document on my old XP machine using an old version of MS word.

I moved it to my new machine, Windows 8, with LibreOffice and loaded it okay, then added several portions and saved the file. It was quite big - about 200 pages of text. It was in rich text format when I loaded it, and when I saved it as I was adding information.

Then I saved the file, which was and is on a USB stick. LibreOffice can’t open it, giving the message: File format eror round at 6520,7 (row, col).

I tried to reopen it on the first (XP) computer and MS Word can’t read it.

I would really like to salvage as much of the document as possible. Can anyone please suggest a file repair program that might help, or any other tool that might able me to rescue most of my work.

Thank you!

Whoops folks! Have continued working on the problem and seem to have solved it by starting new Writer file and inserting the old file I couldn’t open. It seems to have worked! I then resaved as new ODT file, and can open it.

A clever friend suggests that for some reason my installation of LibreOffice is trying to open the Writer file as a spreadsheet file.

In the meantime, I’ve salvaged my afternoon’s work, so have time to work things out.

Similar to my experience, Writer was unable to open the RTF document I was editing. It said “File format error found at 154,7(row,col)”. Fix was to open a new Writer window, choose menu INSERT/TEXT FROM FILE and point to the sick document. It displayed correctly so I save as ODT. (LibreOffice x64)
Thx to Neill1