Can't open MS Word documents after upgrade to Ubuntu 12.04

I just upgraded my Ubuntu laptop from 11.04 to 12.04. I tried to open two documents created by MS Word 97-2003 and they are blank. In MS Word on a Windows system and in WordView on Ubuntu, they look fine with the content I expected. Any idea what’s wrong?

Version is LibreOffice; Build ID: 350m1(Build:2).

I’d attach the relevant files if I were allowed (“allowed file types are ‘.jpg’, ‘.jpeg’, ‘.gif’, ‘.bmp’, ‘.png’, ‘.tiff’, ‘.odt’, ‘.ods’, ‘.odp’, ‘.odg’, ‘.odc’, ‘.odf’, ‘.odi’, ‘.odm’, ‘.ott’, ‘.ots’, ‘.otp’, ‘.otg’, ‘.odb’”).

Instead, here are download links: first .doc file, second .doc file.

Documents also attached to Qubit’s bug report.

@Hugh1, @Netherbury – If you’re able to share these documents with us, that could really help – could you please post copies of the files that you’re trying to open here? We can try to reproduce your problem.

Build ID: 350m1(Build:2)

How do I post copies of the files?

Hi @Hugh1 – To post an attachment, edit your question (use the “edit” link) and then use the paperclip icon in the toolbar (mouseover says “attachment Ctrl-F”)

Thanks @qubit1. Yes, I figured that out. But .doc files are not allowed. Should I change the file extension and upload them that way?

@Hugh1 – Yeah, I see that .doc and .zip are not allowed as allowed file extensions. (1) I’ll go file a bug to see if we can’t get more filetypes allowed here. (2) bugzilla doesn’t doesn’t have the same upload restrictions, so I’ll go open a bug for that (underlying problem might be a bug, anyhow)

Bug about upload restrictions on the Ask.LO site is fdo#52553.

@Hugh1 - sorry, the Ask.LO site is throwing various errors for me. Please go file a bug, upload your example files, and link to it from here. thanks

@Qubit - I filed the bug but it was rejected as a duplicate of yours. I attached the example files to your bug report as now noted in the text of my question

Thank your for posting this question. I was about to do so myself. Although this is not the solution you (and I) are ultimately looking for, a work-around is to install Abiword, open the Word Doc in Abiword, then save under a new name as a doc file. Libre will then open it. This will get you going until the bug is corrected.

Thanks @Netherbury. Fortunately, all I needed to do at the time was forward them to someone else. But this is a good workaround.

Hi @Hugh1,

Thanks for the update. Sorry that your bug report got rejected as a duplicate, but good initiative in tossing the files on my first bug report :slight_smile:

It looks like the first file opens and displays correctly for me using LibreOffice 3.4.4 on Ubuntu 11.10, so that gives us a good starting point for doing some hunting for where/when this regression was introduced. I’ll find some time tomorrow to run bibisect3.5 and post updates to the bug report.

Thanks @qubit1, let me know if there’s anything I can do to help you.

@Hugh1 - Update:

I’ve tested the file using various builds in the 3.5 and 3.6-alpha series, but have not yet been able to reproduce the problem (see the bug report for more).

As we’re getting really close to releasing LO 3.6 (and as you seem gung-ho about finding a fix for this problem :-), you could try installing a release candidate and see if that resolves the issue:

A newer build may also be available through the libreoffice-ppa.

@qubit1: I tried to install libobasis3.6-sdk_3.6.0.4-104_i386 and got the following error: “Dependency is not satisfiable: libobasis3.6-core01.” Is there something else I need to be doing?

@Hugh1 - That might mean a couple of different things, including (1) that you tried to install the language pack first, or (2) that the package conflicts with the installed version of LO. You could try replacing w/this, or perhaps try the 3.5.5 build from the ppa (latter might be easier to install!)

@qubit1 - I didn’t try to install any other packages at all. Just now I tried installing 3.5.5 with Ubuntu Software Center, Synaptic and apt-get and got some variation of “Dependency is not satisfiable: ttf-sil-gentium-basic” on all three.

@qubit1 - Then I found libreoffice_3.5.5~rc3-0ubuntu1~ppa1_i386-2.deb, tried installing it and got “Dependency is not satisfiable: libreoffice-core (=”

@qubit1 - Then I found libreoffice_3.5.5~rc3-0ubuntu1~ppa1_i386-2.deb, tried installing it and got “Dependency is not satisfiable: libreoffice-core (=”

did you add the ppa and then go through that route, or just download the single .deb and try to add it piecemeal? (sorry, I’m far away from my 12.04 test machine so I can only flail my arms and make educated guesses :slight_smile: