Can't open ODS files on Linux

I have LO 410 (Build:3) running on Fedora 19 x64.

I’ve been away for a month, came back, updated my system, and now find that LO won’t open my ODS spreadsheets. It opens XLS spreadsheets fine. None of these are complicated or large. It brings up the splash screen and then just fails. If I open LO without a file and try and open an ODS spreadsheet it crashes.

I’ve tried removing my profile to no effect.

Opening the file from the command line brings up:

/usr/lib64/libreoffice/program/soffice.bin: symbol lookup error: /usr/lib64/libreoffice/program/…/program/ undefined symbol: _ZN20XMLPropertySetMapperC1EPK19XMLPropertyMapEntryRK12UniReferenceI25XMLPropertyHandlerFactoryE




For some reason the “libreoffice-calc” package wasn’t installed. Not sure how that happened - last edited an ODS file on 16 Feb and went away on the 17th, and it was working before. Also, it was working with XLS spreadsheets.

Anyway, installed above package and it all magically popped into life.

It looks like you have already have had LibreOffice Calc installed - if not then you opened Excel file with some other program. When you install libreoffice-calc there is a change that just a newer version of program was installed. Maybe the update came out that was corrupted and now you installed new version of package that has a fix… It is hard to say what really happened.

This sounds like a problem which is already reported under fdo#74235.

Thanks for your reply, but definitely different.

  1. Every .ods file I’ve tried has failed (also occurs with some sample .ods files I found here: - that bug was only with a particular .ods file.
  2. That bug gets further before crashing - I never get a display of sheets and cells.
  3. Removing styles.xml from my file has no effect.