Can't open or edit slides

The slides on my presentation do not appear in the editing area. When I create a new slide, I am unable to insert any text box/chart etc and the slide does not appear. I have tried going through the navigator on the left side and the panel on the right, I have restarted my PC and tried restarting the application. Creating a new presentation works, and I am able to edit the slides regularly, but when I open this file it does not work correctly.


Please try “Safe mode” and read this discription.

Make a copy of the faulty file.
Add the makro (see below) to a module in your “Standard” library or a new library.
Open the copy of the file and run the makro.
If you do not get it work, send me ( the file, and I’ll repair it.

REM  *****  BASIC  *****
option explicit

sub SetAllLayerToDefault
on error goto errorend
dim oDocument as variant: oDocument = ThisComponent
dim oCurrentController as variant: oCurrentController = ThisComponent.getCurrentController()
if not(oCurrentController.supportsService("")) then
    msgbox("Macro works only on Draw and Impress documents.")
    exit sub
end if

dim aLayerManager as variant: aLayerManager = oDocument.LayerManager
dim nLayerCount as integer: nLayerCount = aLayerManager.Count
if nLayerCount <= 0 then
    msgbox("No layers found.")
    exit sub
end if

dim aLayer as variant
dim nIndex as integer
for nIndex = 0 to nLayerCount-1
    aLayer = aLayerManager.getByIndex(nIndex)
    aLayer.IsVisible = true
    aLayer.IsPrintable = true
    aLayer.IsLocked = false
next nIndex
exit sub
errorend: exit sub
end sub

This worked, thank you!