can't paste old .doc file

I was going through old files on my pc. I found a .doc file from 2012. I tried opening it in LibreOffice, my current word processor, and got ‘not a winword document’. Puzzled, I tried opening it WordPad, which promptly crashed. Then I tried Notepad with success.

If you’ve ever opened a word processing file in a plain text app like Notepad, you know what I got – a bunch of gibberish. But I was able to find the actual text, so I thought, ‘no problem’, I’ll just copy paste it into LibreOffice and edit it (all formatting was gone) from there. But not so much.

It pasted about ¼ of the text I had highlighted. I figured maybe there was some code hiding in the gibberish that was making the text that didn’t copy ‘invisible’, sort of like commenting out something in html. So I cut all that stuff out of the notepad document, but the copy paste was the same result.

I took a careful look at where the part that did copy started and stopped and realized there were actually sections where it copied, then skipped, then copied. And the cut off was right in the middle of a word, which made no sense if it was like commenting out text in html.

Then I noticed the default save was ANSI, so I tried UTF-8 and Unicode – the only difference was that LibreOffice could now open it as a plain text file, but it looks exactly the same as the copy paste version.

By deleting all the blank seeming spaces between surrounding one paragraph that didn’t show up, I was able to make it show up, but that same trick didn’t work on the next paragraph.

When I came here to post about this curious behavior, I did a search for similar questions. I didn’t find one, but I did find this one: Text disappeared from document, is there any way to recover?
and that gave me the idea to try pasting it directly from Notepad into Google Drive. Well, lo and behold, it seems to have pasted the whole thing just fine.

What is going on here? If Google Drive can handle it, should this be reported as a bug in LibreOffice? I am on Windows 10, with a Dell XPS 1820, LibreOffice

It’s impossible to say anything if the reproduction is impossible.

You may create a bug report at, and attach the document there.
However, to truly reproduce the described behavior, clipboard contents is required, which may be obtained and saved as separate file using tools like InsideClipboard. The clipboard contents should be also attached to the bug report.

Be warned though that attachments are public, so you should make sure that you don’t publish sensitive information.