Can't paste plain-text when copying from websites into Writer

Hi there, am trying to paste plain-text from websites into Writer. I can copy OK but the plain-text is greyed out in Writer when I come to paste. So I am forced to use the normal ‘paste’ command and then the formatting is all off (as it brings in formatting from the site). I’ve also tried ctrl+shift+v but that doesn’t do anything for me.

I am using Peppermint OS 32 bit edition and LO 4022. I’ve recently migrated over from Windows 7 and using Word.

I’m frequently needing to copy/paste from online into written docs so am really hoping I can fix this.

The document is a docx that I started in Writer but have been saving in docx format.


When you try [Ctrl] + [Alt] + [V], do you select “Unformatted text”? Please check this answer: Writer : The styles could not alter the paragraph font - #4 by carnendil

When you go to Edit - Paste Special, which is the same as Ctrl + Shift + V, it doesn’t give you the “Unformatted text” option? This is what you want. I just tried copying from the website into LibreOffice and LO on Linux systems and they both worked the same, Paste Special gives you the choice between HTML and unformatted text…

The issue may be the docx part - I have found docx is a little finicky in LO, if I must use people’s word documents from windows I usually resave them as .doc instead of docx, or better yet .odt if you can as this will give you the most functionality in LO. I don’t know for sure though - try it and see if it works.

Thx for reply. Seems it may be a Chrome issue. I have tried creating a new document (standard ODT and saving) and I CAN use ‘paste special’ when copying FROM other text documents (incl my docx doc), and when pasting from PDFs. However, as soon as I try and copy/paste ANY text from chrome, I only get the ‘paste’ command and the other paste options are greyed-out. This means I pull in unwanted formatting/links, etc. Guess I can try on another browser (none others installed on here yet tho).

UPDATE. It’s now working. Very odd. I was flicking through different windows, followed the link above to that other Q&A, didn’t really do anything at all, copied another bit of website text, hovered over ‘paste’ icon in toolbar, suddenly I can paste ANYTHING unformatted now, both from menu and/or using paste icon. But it definitely WAS grayed out ystrdy and first thing today, no matter what I tried. Works both in docx and odt for me now too, no problem at all!!!

@mattsinc Glad you got it solved.