Can't print from Libre Office Writer

When I try to print a document from my Documents File, Libre shows a pop-up that is for Sending Fax and not for printing. I obviously have made a change that I’m not aware of. I need to print this document…HELP!!!

Usually you should get a dialogue first, where you can select wich pages you print etc.
Do you get this dialogue?

There you can also select several printers. Some are virtual printers to capure the output as pdf, but your printer should be in the list.
Select it and try to print.

If your printer is not shown, try to export to pdf, open the pdf (not in LibreOffice please) and try to print it. If you have the same problem as before, you may need to reinstall your printer or just tell your Operating system, wich printer is default. Eventually reboot.

If this doesn’t help, please extend (edit) your question to include your used operation system and the version of LibreOffice.

I go to my Documents Folder and choose which document I want to print. I open it and it opens in Libre Office Writer and then I select Print. I only have one printer and it is the Default Printer. When I do that, a window pops up that is titled “Send Fax”. The document doesn’t go to the printer. Everything was working perfectly yesterday. This just happened overnight. I am using Windows 10 and the Libre Office is 7.0.3.1 (x64)

Seems I have to check my settings tomorrow, as I left my computer installing Win10 updates…

What is the Name of the selected driver in the dialogue?
Win10 had recently some issues concerning printer drivers, so maybe we can find out something… (Name of the selected driver, not name of your actual printer, even if this max be also useful.)

On first boot of Windows 10 you already have 4 printers: Fax, Microsoft Print to PDF, Microsoft XPS Document Writer, & OneNote for Windows 10. See Control Panel > Devices and Printers
If you install a new printer that has fax capabilities you get two more printers: My Very Long Printer Name, and My Very Long Printer Name Fax.
If you accidentally set My Very Long Printer Name Fax as default or in File > Printer settings then it will always try to print to fax. This has happened to me so I tend to remove fax drivers when I am driven to it.
If your My Very Long Printer Name printer is unavailable to print, then Windows might offer the first printer in the list, Fax
Maybe just Restart (Not Power Off) your system and things might return to normal as the printer is supplied by the operating system and also restart might wake up the printer too.

Sorry, I don’t know how to find out what driver is installed. I’m “tech-illiterate”.

I only have 3 printers: Canon TR8600 Series (Default), FAX and Microsoft Print to PDF. When we bought this Canon printer 3 weeks ago I used Revo Uninstaller to absolutely remove every remnant of the HP printer we previously had installed. But as I mentioned, this printer was printing from my Documents folder just yesterday. And today it will print any email I direct it to. I Restarted the system as you suggested and it didn’t change anything.

As @Wanderer says it might be related to Windows 10 update to v 21H1 which is being rolled out widely now. See Microsoft website.
LibreOffice 7.0.3.1 is an early version of the LO 7.x, there have been bug fixes since then. Try updating to LibreOffice 7.1.5.2 which is not the latest stable release but is linked near the bottom of the download page under Available, 7.1.5

Okay, where is the download page?

Okay, I finally found where to download 7.1.5.2 and just completed it. No change. Can easily print any of my emails but can’t print any of my documents. Oh, and W-10 is up to date on my machine and I ran a troubleshooting scan on it and found nothing.

Well I have come just short of pulling out all my hair. Everything on my computer says my Canon TR8600 Series Printer is the default printer…but I just ran a troubleshooter on the printer and it came up saying my problem might be solved if I let the trouble shooter make the TR8600 Series my Default Printer. Okay, I’m open for anything at this point…short of throwing the printer out the window. I let the trouble shooter set the default and now everything is working as it should!!! I hate computers!!!

Thanks for your help. What a mess this has been!