Can't quickly open hyperlinked word/number if there are no hyperlinked word/number in the same cell (LibreOffice Calc)

[I changed a little the question cause the issue was another thing]
Hi, i have a little question; do you know why or how can i change the fact that, i can’t quickly access/open an word/number hyperlink if there is a word/number without hyperlink in the same cell? I mean, when there are hyperlinks on a word/number in a cell (it means, ALL the cell is hyperlinked), i can pass my mouse cursor over the word/number and i can Cntr+LeftClick to open it without open/select the cell, but when the hyperlink is on a single word/number and there are more in the cell with no hyperlink, there is no option to Cntr+LeftClick open it, i have to select/open the cell and then i can open the link pressing in the word/number with the hyperlink. Also, i put the hyperlink with the “insert hyperink” tool. I Don’t know if LibreOffice has not this feature (i’m using the last one, 7.6.2), if i have to configure something or if is a OS thing or PC thing (i’m on Asus laptop with windows 10). Thank you and sorry for my enlgish.

Welcome to you, @Chabannes!

This is strange, it works for me:

Which version of LO do you use? (Add it to your initial post)

If just one word is hyperlinked then you need to be over the hyperlinked word before you can Ctrl+Click. There might be two hyperlinks in the same cell so you need a way to select which one, hovering over them will show which is which.

2HyperlinksInSameCell.ods (9.6 KB)

Hi, thanks but, actually, the problem occurs when there is only one hyperlink. When i have more than one, i also can select the one i want, but when there is only one word hyperlinked and other words without, i can’t. But the most weird is if i open your calc file and i delete the second hyperlink, i actually can open the only one; so i guess it has to be something in my calc file setting or something. I just find that when i put the cell content to the left, the links appear, but when i put the content to the center of the cell, it’s not possible. So i don’t understand anything but i resolved the problem. Thank you anyway for your reply,

I cannot replicate your issue.

I did once have a slightly different issue in selecting and editing data in the address bar when occasionally it seemed I was editing in a different place in the cell. It turned out that it was a graphics issue that was solved by clicking Tools > Options > LibreOffice > View and ticking the box Force Skia software rendering

I find out that is just when you centre the text of the cell. I guess it’s cause LO is no longer able to correctly detect “where” is the text, so even if you are pointing the word with the mous cursor, you are not really selecting the word, or something liek that. I’m going to try your advice just in case.

I cannot replicate with centered, wrapped, right-aligned, partly hidden, etc.

Please click Help > About LibreOffice and click the icon just after Version Information to copy the information, paste into your question (click pencil icon) or into a comment if you cannot edit your question.

Unfortunately this is a very, very old bug:

1 Like

You are absolutely correct. I had wrap on as well from my testing and the hyperlink still works; if I turn off word wrap then it doesn’t.

@Chabannes Workaround: turn on Word Wrap even if it doesn’t need it

Well, at least i find the source of the problem, so i can avoid it. Thanks you for your participation.