Can't run installer Win7

I downloaded the LO 4.1.4 installer from the site, but when I try to run it, it doesn’t work. First I get a precautionary ‘Windows can’t verify program publisher’ which I’m sure is just saying ‘this isn’t Microsoft!’. So I ignore it and tell it to run the program anyway.

I get an unhappy sound and a message pops up: “This installation package could not be opened. Contact the application vendor to verify that this is a valid Windows Installer package.”

I’m running Windows 7, 64 bit version. I don’t think I’ve ever used a .msi before, but I certainly have never installed LibreOffice before. I’m currently without a word processor other than Notepad. I’d be more than happy to use an older version of LO is that solves my problem.

Installation of LibO using an msi file is extremely easy. Thus there must be another problem.

Could you please inform:

  • on the site from where you downloaded the LibO msi file?
  • what exaclty yuu did to install the SW?

I downloaded the .msi from the main link on the download page of, the top of the two green buttons.
I saved the file to my computer, then double-clicked on it to run it.

I had the same problem. My original download file was 5000 kb, but when I re downloaded it it was over 17000 kb. I got a little further the second try, but still wasn’t able to install. I got error 1335. Told me that the file was corrupted and couldn’t be used. I tried downloading a third time and the file size was 210904 kb and the install was successful.

@Kelley - Thanks for adding the information about the file size. For 4.1.4 the filesize should indeed be 210MB. Looking at file size changes since 3.5 there is always a slight increase for added functionalities.

Same problem for me. Current version of Win7 - plenty of memory and disk space. Third download attempt from the official site. Now back to the “installation package cannot be opened” message (see above). Tried double click and right click and selected “Install”. Neither works. Got as far as the CAB file corruption message before. Please don’t insult my intelligence by claiming an OS problems. Everything else installs fine. Not encouraging at all.

Nobody is calling you stupid, @davidoma. It’s just impossible to know what exactly is going on without a lot of detailed info. It is possible that LibreOffice uses parts of the operating system that nothing else you’ve installed does. It’s possible that the problem is extremely recent and nothing else could have hit upon it.

You downloaded the file from a save site.

Now it could be that the download got corrupt. Did you try to download the file again?

If the download is not corrupt I think this has to do with you OS.

Please have a look at these links for OS matters:

Additionally you can search the web using 'Windows can’t verify program publisher"

I downloaded from the main link on the download page of . I’ll try downloading it again in case of a glitch during the download.