Can't see headings

Using LibreOffice and Mac OS X 10.8.5 I can’t see any headings anymore?

Im starting a new document, selecting some text and select “Heading 1” in the Apply Style dropdown box. Something happens, but the text still looks as it did before.

What is happening?


The first part of your describtion sounds as if the headings disappear and the second part as if a heading style is not applied also you applied it.

Let me go to the second part.
I would do the following:

  • Take a brand new file
  • Type a line with a carriage return in the middle
  • Apply a heading style to this line from the style drop down box
  • Place cursor in the somewhere in the text of this line
  • Open the style window (F11)
  • select the heading style you applied
  • right click on the style and select “modify”
  • check if the settings match with what you see or what you expect.

If you still have a problem, please report your findings and you will get some help.

Thanks for your reply. I did as you wrote, and it worked like it normally does - no problems. So I copied all my text from my document to a clear text editor, and made a new document and pasted it in. After that, I could apply styles to my headings!

So obviously, something was wrong in the document I had worked on. But what - I can’t tell!

@KasperDK - If you jsut want to eliminate all direct formatting you also can select the entire document and right click in the selected area and use “Clear direct formatting”. Only default styles remains.

If you have this problem, and your document is not too long, you can try to copy all the text from the document to a clear text editor, and paste it into a clear text editor (to loose the formatting). Then make a new document, and copy the clear text and paste it into Writer. Then you can apply styles.

That worked for me.