Can't select single table column

When I hover above a column (down arrow appears) and click the left mouse button, the column below the arrow is normally selected (Highlighted), so I can make changes to text formatting…

Now when I do the same it selects the desired column as well as the adjacent ones, all but the last one in the table.

For reference:
I did not change a thing to the document nor program settings, and it worked fine before. I can not find anything in the table or paragraph settings that could indicate the columns being linked to each other somehow.

I have also noticed that after a few tries of opening and closing any settings, and I try again, the highlighted columns loose the highlight when the settings dialog opens, and only the top left fields text (not the field itself) is highlighted, and any changes I make are applied to that text only, not to my original selection of columns. Once this has occurred, the results always repeat until I close the document, and re-open it.

LibreOffice Version:
Build ID: 1:5.2.2-0ubuntu2
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default;
Locale: en-US (en_US.UTF-8); Calc: group

perhaps if you select the column in another way, right-click somewhere in the column, then in the contextmenu choose Select: Columns

I have tried every which way, but nothing works. I have reset my user profile, installed the LibreOffice Fresh ppa’s and LO 5.3…, and filed a bug report and uploaded the suspect files for testing, so far nothing has worked, and no one else has confirmed to have the same problem, nor have the people investigating the bug got back to me. It’s not even supposed to be possible.

We will just have to wait. Strange though that I am the only one with this problem. :frowning:


The cause of the problem is that you have merged two cells into your “Totals” line.

Therefore, the selection with the mouse works as you indicate.
As V Stuart Foote says it always worked like this (already with

The solution is to re-split the cells and remove the middle border to get the look you want.


Removing the border is as much possible in Writer as it is in Calc.

You have to click twice: the first time the selection becomes gray, the second it becomes white

image description


Hi Pierre, you are everywhere!

I tried that and just tried again, but I get nothing. It would be great if a lot more of these settings in LO had a “live Preview”. What ever happened to “Format Cells”?

Oh, and if I do get that to work, will it fix the text? It is wrapped in a cell, not in a single line anymore.


I gave you the advice to re-split the cells because the text of your sample file was short (Total). So there was no problem with returning to the line.

If for other cases you have longer texts, another solution could be to split your table (to separate the total from the rest of the table) and reduce the height of the paragraph to the maximum, even to hide the paragraph.

That said, personally, I would not do all this just for this problem of selection with the mouse …

Hi Pierre, the other sample file had “Total for parts and materials:”, and I can not agree more: It’s not worth all that, just to select a few cells.

BTW, thanks for pointing that out, I just changed “Total:” to “Total for labor:”… consistency!

So the people at Bugzilla figured it out:

Seems that because the last row in the table had merged cells, trying to select any one of the columns above that cell, selects them all. I did that for layout reasons.

I was told to un-merge the cells and remove the inner borders to make it look like one longer cell, but it wont let me do that (I think that only works in calc), I tried a few ways. It also wraps the text in one cell, rather than spanning across the cells. Not the look I was going for.

Lucky for me, the [shift] click and drag method works to select everything in the column up to the merged cell, so I can edit the contents, and it does not screw up my layout. :slight_smile:

Sorry need more Karma to upload pictures, in order to give you the visuals. :frowning:

@Zoidman I think you did not refresh the page in your browser. You would have seen that I had answered you in Bugzilla and here :slight_smile:

See my edit in my previous answer.