Carlito font displaying issue

When I use the Carlito font in libre writer, it displays some fonts combination improperly. They are “ti, fi, tt”.

For better understanding I attached screenshot. I wanna know it’s a problem of OS or of Libre Office? I’m using Zorin OS 16.2 with latest updated apps.

This is called a ligature. Common fonts include replacement for selected pairs of characters. This feature is inherited from traditional typography. You find such “aesthetic” effect for ff, fi, fl, ffi and ffl but font designers are free to add more kerning pairs.

I had a look at Carlito Features (a button in the Font tab of paragraph and character styles). Many “standard ligatures” are defined in liga table. If you have FontForge utility installed, you can display the full list. “tti” is one of them. ~150 are defined.

What is weird is ticking or unticking the Standard Ligatures check box does not change ligature substitution: it is always effective.

EDIT: I just checked; same behaviour in KWrite, a text editor.

With my Carlito ttf font (2013, Version 1.103, Beta 1), unticking Standard Ligatures removed the usual ligatures but instead of just one change to the font it was a string of them: Carlito:liga=0&ss01=0&ss02=0&ss03=0&ss04=0. Just copying Carlito:liga=0 into the Font name box in the paragraph style should result in no ligatures.

There is a one pixel gap between the f and f

On the downside, italics don’t work correctly, even without changing away from ligature. I notice Carlito is not available on Google fonts today; maybe a bit buggy?

This Carlito font works fine in Only Office by default settings.

With “fine” you mean " without ligatures"?

IMHO it is not a problem, but a feature of the font. As LO also have the possibility to switch this off I see no problem at all… (for english language. In german for example there are combined words like “Sauerstoffflasche” for a “bottle with oxygen”, where one may be interested to prevent a ligature for the triple-f, but may use ff- and fl-ligature).
One additional hint to an extension Typography Toolbar, I detected when working with “smart fonts”. I can’t test now, but use may be easier than using text-parameters for fonts:

I cannot get error in italics again, it might have been from me when I kept changing settings in Features until it went bad…

Displaying ligatures isn’t an error, it is an intentional choice by the font designer. In the following image using Times New Roman, the first line is a bit awkward, especially the fi combination. Compare that to the second line with ligatures enabled, it is just cleaner and draws the eye along the line.

By default settings, Only Office doesn’t not combine those fonts.

Now I knew that this is not an issue rather it is a choice.

Anyone can tell me a simple method to disable font ligature so that those fonts don’t combine…?

See comments above

Or you could use the user interface. In the example below Carlito has been set in the default paragraph style so it will apply to the child styles. Click the Features button and untick Standard Ligatures.

It will also set the four alternative sylistic sets for the font to 0 (disabled) as can be seen

Use the Carlito:liga=0 in your styles. LibreOffice has no central setting wich would break the layout of a document you download for example. You can only modify your templates.
Compare it to language. My default is german, but this is not enforced for english documents I download and I can even mix languages in one document. So don’t expect easy switches.
Also think of other glyphs, like in arab or asian language. They may need, what you dislike: a font-renderer, wich can use kerning, hinting, ligatures…

1 Like

You may want to turn this in an answer. An alternative syntax is Carlito:-liga.

Your solution is undoubtedly effective. But if there were an option to disable font ligature, it would be easier and convenient. Because I use English and Bengali, two languages in my writing. They need two different fonts.

The option is there: format these parts where no ligatures are desired with the Carlito:-liga font. Indicate this once in a paragraph style and/or in a character style and you do not need to look back. Could not be much easier.

1 Like