Cell overtyping issue in calc

Hello, I have a cell overtype issue in calc (v5.1.5.2 on Ubuntu Mate 16.04.1) where after a spreadsheet is saved then typing in a cell becomes unreadable, especially if you edit the contents by overtyping. Expected behaviour is seen prior to saving.
The first pic shows 2 cells in a saved file. the word “typing” in both, then in the lower cell I have selected it and type “overtyping” in it. You can see the result. Expected behaviour is not to see both entries, thus obscuring what I am trying to see. (http://www.picpaste.com/xjgZKAj9.png)

This also happens with numbers as per (http://www.picpaste.com/715V8C0V.png) which is the number 100 in both cells then typing 150 in the lower.

If a new sheet is created, prior to a save this behaviour is not seen.

Thoughts? Tips? Help?


What helped me: Tools / Options / View. Turn on option “Use full OpenGL rendering (requires restart)”.

Slightly looks like one of the rendering issues related to OpenGL. Did you deselect the option ‘Use OpenGL for all rendering’ underr > ‘Tools’ > ‘LibreOffice’ > ‘View’ already?

(Editing with respect to the comment below:)
As the issue obviously is one of rendering the only other cause (specific to LibO) I can think of, is a corrupted user profile controlling the rendering wrongly. You can backup yours and try a new one as described here.

If there should be a system (OS, hardware) issue behind your problem, I am lost.

Thanks, yes I have already deselected that. Here are my settings for rendering http://www.picpaste.com/u1kQ153J.png

Thanks again, that didn’t work either. It is pretty much a fresh install as part of trying to resolve this i uninstalled and reinstalled. Perhaps a bug report needed but I’ll keep looking into possible system causes too.

Surely your Ubuntu came with Wine. Did you ever try different versions of LibO from packages in the PortableApps. format (.paf.exe)? These versions (Win 32 bit) can be unpacked and run under Wine even without the platform. It might be interesting whether the (most recent) portable V5.1.4.2 also will show the problem on your system. It should run independent of system settings made during the installation of your present version. It will also create its own user profile, of course.

I’m not sure with Ubuntu, but uninstall and reinstall doesn’t clean the user profile.

Hi, I had similar issues on my Kubuntu notebook, have tried different approaches, but what helped was to uninstall libobasis5.3-gnome-integration package.

I also deleted all ~/config/gtk* files and folder in my user directory. Not sure whether this helped me and can’t suggest as this files may be important for your Mate desktop. I still think that the first step (libobasis5.3-gnome-integration removal) solved the problem.

You could try to check whether this or similar package is installed in your system. Try to uninstall it then.


I have unistalled my libreoffice installation which came from libreoffice.org download page and installed stock libreoffice from ubuntu repository (5.6.1). I don’t experience the issue, though I experienced it with both ubuntu and libreoffice.org versions. Ubuntu version hasn’t the libobasis5.3-gnome-integration package so I suppose something could be wrong with ~/.config/gtk* files and folders.