Change grammar default to 2 spaces between sentences - solved

Using Linux LibreOffice and LanguageTool. I always have 2 spaces between the end of one sentence and the beginning of the next. As I have done in this post as an example. (Although on posting it seems an automated typesetting messes that up). LT or LO sees this as an error and marks each sentence start as having an ‘extra’ space. This is annoying, but more so, it swamps the page with ‘errors’ when there are none and slows down LT as it attempts to address each or this spurious ‘errors’. Where is the setting to change the spaces between sentences to 2. I am not interested in an argument about 1 or 2 spaces. I use two and have reasons for that, I just want the grammar check to stop throwing it up as an error. (If this is a LanguageTool thing, can someone point me in the right direction for that.)



“Although on posting it seems an automated typesetting messes that up”

That is as a result of how web browsers display multiple white space (tabs, spaces, newlines etc) - as one space.

This seems to be a notification by LT. I haven’t it installed and I’ve no warning on double (triple, …) spaces anywhere. So, temporarily disable LT or don’t spell check while typing.

I am not interested in an argument about 1 or 2 spaces.

Be aware then it messes up the justification algorithm. It is not, and never was, in professional typographical rules. It was set up in the typewriter era with fixed-pitch character to compensate for very limited formatting possibilities, notably to distinguish between abbreviations and end of sentence.

You are correct, it does appear to be a LT issue and about the typographical background to this issue. The reason I want 2 spaces is for the preparation of correctly set up PDF files for professional printing. Two spaces between sentences is more aesthetically pleasing and dramatically increases the readabilty and comprehension of the prose - this isn’t my opinion there has been a lot of research on this - regardless of font type, which was the whole reason for getting rid of 2 spaces.
I’ll head off to LT and see if they can tell me where this setting is. Thanks for the reply.