Change page numbering in the content-field

Please help, I need to set my index (content-field) to show page numbers not in arabic (3) but roman (III) style. On each page it displays roman as I set it but in my index it displays still arabic even when I refresh it.

1 Introduction…3
2 Analysis…5

1 Introduction…III
2 Analysis…V

Thank you very much for any ideas

I interpret your “content-field” as Table Of Contents (TOC).

Open Style window (F11)
Click Page Style
Right click on the style you want to modify ( Default maybe) select New or Modify (depends on your needs)
Click on tab Page

image description

Change Format to roman numerals
Click Apply and OK

==> your pages numbering should now appear as roman numerals

right click in you TOC and select Update index / table

==> your page numbers should now appear as roman numerals

If you need to have roman numerals and arab numerals you need to created different page styles and apply them according to your needs. Take care of the “Next style” setting.

I recommend to have a look at

Additionally I posted a related small enhancement request fdo#67973