Change standard format of Export and standard file format

Hello everyone,

i’m exporting a lot of graphics for my Anki from a book (pdf). To maintain scalable graphics i’m exporting them as SVGs. Also i’m never exporting a whole page.

So the whole time i have to manually chose “Selection” while exporting and also SVG as the file format. Is there any way to change the default behaviour of the “Selection” Checkbox and also the file format of the export dialog?
It’s not under Load/Save as this only applies to the normal saving procedure of Libre Draw and not the “Export” dialog.

It’s really annoying to always do these extra steps. If someone has a better way for extracting graphics from pdfs, sharing would be really appreciated. I don’t want to do screenshots, as these take up more space, are lossy in quality and also not transparent which looks distracting when using Anki in night mode.

1 Like

There are specialized tools for this like:

In Draw I would suggest to use/create a macro with your options to save.

Thank you for your suggestion, but there are two things:

  1. The recommended software is proprietary and windows only
  2. Although I haven’t checked it, I bet graphics are rasterization only, so PNG or JPG, and not vector based and/or text including, therefore we will have a loss of information and quality again. This would be at an equal level as a screenshot.

You could use Inkscape which will happily save as Inkscape SVG by default and opens SVGs more reliably. You will still have an extra step, this time sizing page to selection (Ctrl+Shift+R) before final save.

Note that in LibreOffice, if you have ticked Use LibreOffice dialogue boxes in Tools > Options > LibreOffice > General then, if you have something selected when you export, it seems to tick the Selection box automatically for you.

Hi there,
I’m in the same situation as you, as wanting to save ALL my drawings in ODG and export ALL to SVG, and found that extra step is needed.
Searched through the whole bunch of config files, in my opensuse machine, and no luck.
Maybe it is hardcoded in the source (yucks if it is this way), as this should be a config option.
Maybe it is time to look into the code…
Could some developer confirm this?
Thanks to all for the good job, and just waiting for an answer.

This isn’t the place to ask for enhancements nor report bugs, see How to Report Bugs in LibreOffice - The Document Foundation Wiki