Change straight quote marks to curly

Am new to LibreOffice. Have V on a Mac. I’ve tried many suggestions found on this site but cannot work it so that quote marks, both single and double, are curly. Can anyone try to guide me through this? Thank you in advance.

This is a question about your input methods, not much to do with LibreOffice. Try Ilya Birman’s layout, it allows input of many characters unavailable with conventional layouts (well, Linux users will only scoff at the last part of this).

Hi there and thank you. Are you suggesting that I’m not getting curly marks because of my keyboard, and that if I download Ilya Birman’s layout I’ll be able to see the curly marks?

Yes, you will be able to input and see curly quotation marks in any program.

On one side you have the option to use Menu/Insert/Special Character, where you can find all for the font.

On the other, there is an option in Menu/Tools/Autocorrect/Localized Options - for how to replace single and double quotes at the start/end.

Single and double quotes

Hello and thank you. Your first suggestion I understand and can actually accomplish, but this is tedious and I’d like to change the output to curly as default.

The second suggestion I’ve tried but can’t seem to fully accomplish. I’ve “Replaced” all the single and double curly marks in the Localized Options and entered “OK” but when I type I still see only straight marks. I’m wondering whether, as the previous answer by “gabix” suggests, I have to adjust my keyboard somehow.

For me second choice works fine.