Change unwanted Russian prompts back to English

I use the version listed below. Note the Cyrillic. My option settings are on U.S. English and I am unaware of causing the foreign language to appear! How to get rid of the Cyrillic?

Version: (x64) Build ID:
Потоков ЦП: 8; ОС:Windows 6.19;
Отрисовка ИП: по умолчанию; Locale:
en-US (en_US); Calc: group

you should change language for LibreOffice GUI in dialogue Options:

For Cyrilic GUI select menu Сервис-Параметры, in dialogue left select Настройки языка-Языки, and right select from drop-down list Пользовательский интерфейс variant Английский (США)