Changing data point icon in spreadsheet charts not working?

I want to change the icons used for data points in a spreadsheet chart. I know how to do this: Format Data Series>Line>Icon and pick from the menu. The problem is, it doesn’t work! The default value was a triangle. I tried picking all sorts of different options, and none of them work, it just stays as a triangle. Then I tried “No Symbol” and that worked - the triangles disappeared. Now I can’t even get the triangles to come back. Is this a bug in LibreOffice? Help!

ETA: I tried safe mode, no difference. I did manage to reset the chart defaults, but I still can’t actually choose a different icon. I’m on a MacBook Pro, running macOS Mojave Version 10.14.6. LibreOffice Version:

In general theres no bug, but bugs may depend on various parameters like your LibreOffice Version and/or your operating system. None of these are mentioned and thus everything needs to be guesswork.

Have you tried in Safe Mode whether your problem persists?

Hint: To get the defaults back, double click the chart, right click and re-select the chart type.

I have the identical problem and have been using LibreOffice on Linux for years. This seems to be an issue specifically in 6.4, as I have had no problem changing the chart symbols in earlier versions. I can only get the small boxes to appear regardless of which symbol I choose from the list.

Kubuntu 20.04
LibreOffice Version:
Build ID: 1:6.4.2-0ubuntu3
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: kf5;
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

DETAILS June 6, 2020: I was able to find a workaround for the problem referenced by the original poster of not being able to change the icon type in a LibreOffice Calc Chart. However, it required downgrading or upgrading to LibreOffice (Version or up to the LibreOffice 7 beta version.

Claim: The problem of NOT being able to change the icons in a Calc chart is almost certainly isolated to LibreOffice 6.

Evidence Backing Claim I tested the ability to change the icon of a Calc chart in three LibreOffice versions:, 6.4, and 7.0 beta. I was able to successfully change the icons in LibreOffice and the LibreOffice 7.0 beta version.

Logic connecting evidence to claim. Because I was able to successfully change the icon in and 7 beta, this strongly suggests the problem is isolated to version 6.X. This is further supported by the facted that SeijiSensei also commented that he had similar problems on his Linux installation of 6.X, which bolsters the support that it’s the version and reduces the possibility of this being a combo error (OS & version). I assume that I installed the different versions (, 6.4, and 7 beta) without error and that having all three on the same system would not cause any unexpected behavior. Of note, I only had one version open at a time when testing.

Short-term Solution: Use if it’s that important to switch icons.

Long-term Solution: It appears 7.X will fix the problem, but the beta version isn’t stable enough for daily use. As an example, it appears 7 beta is not able to load files from disks as I had to manually recreate the data in Calc to run the test. The “File-> Open” workflow would spin without any resolution.

My computer:

MacBook Pro (13-inch, Mid 2012)

OS: 10.15.4 (19E287)

I see a slightly different bug: I am able to change the symbol, but after I save to xls, exit LOC, open the xls file again, then the symbol has changed to white on white (chart background is white). That is with LOC (x86) on 64 bit win 7. (Note it is not easy to click on a white on white symbol to modify it. That is a symptom of the fact that the whole chart UI should be overhauled. All properties should be in a visible tree, much like file structure is often presented.)

This doesn’t sound like an answer to the original question but another problem description. Please delete this post and ask your own question or file a bug report here, if you assume a bug.