Changing default font

I know there have been other questions like but none answer what seems to be going on in my situation. The default font in Writer is set to Courier. I am on a mac so to change this I go to LibreOffice–Preferences–Options–LibreOffice Writer–Basic Fonts (Western). Then I go ahead and change all the fonts to Times New Roman. Fine. Then I close the program and when I reopen it it is set back to Courier. Why is this? I have created a template that has TNR set as the font and I have set that template to default. This gets it done but it seems a work-around. Why won’t it change in the Preferences? As state I am on a mac and I am using LibO

Please update the question to include key detail. Thanks.

I’m hoping for answer to that too. It’s spring of -18 and issue is still open. Is there anybody able to to do something about it??

I have been searching for a solution for default font. So far I have not found any answer. One of the answers refers to an item Basic Fonts. I do not have such an item under Tools > Options > Checked everything. I use LibreOffice 5.

Have the same problem and can’t find an answer.

This is not an anwer!
The thread is old (>2 1/2 y) and about a rather outdated version (5.1.1) of LibO on an unspecified version of Mac OSX. Not a good chance to get a useful answer.

As the thread had a revival, I would like to point at least in the direction of the ‘Standard’ template. There is nothing like the of MS Word. The internal default template used by LibO should not be editable. Thus you need to create a template with the styles you need and modified as you like it, and additional styles as appropriat for your purposes. Save this tamplate. Then use the template manager to import it and make it your ‘Standard’ template. Hence this template will be used if you create a new Writer document without explicitly specifying a template.

This is not trying to answer the original question which I most likely did not understand, if not the described behaviour was due to user profile corruption. .