Changing default settings when importing .csv into Calc

I have to import a lot of different .csv files, and in order to get Calc to recognize that there are numbers instead of text, I have to change the Column type from “Standard” to “US English”. I primarily use Linux Mint with the current stable Libre Office. I have this problem all the time so I don’t think it has to do with the Libre Office version or the Linux Mint version. (But could be because it is Linux Mint.) Currently I have to go through and change every column that has numbers to US English which is annoying.
Eric Rothoff

You could convert .csv to .ods with filter options from the command line or in a macro used to import into a document. See CSV Filter parameters and How to set up FilterOptions to open/import a CSV file? - #3 by Villeroy for a snippet to obtain the currently used filter options of a freshly imported .csv file.

Note also, that the locale to use on the CSV import in general (as opposed to per-column setting) is set at the top of the import dialog, and is remembered for the future use (unlike per-column settings). It has nothing to do with your locale, only with CSV locale. Maybe just choose English (USA) there, and free yourself from setting columns individually.


On the import dialog box, I did not have anything to select for Locale, but I did have Character set, and Language. The Language was set to Default - English (USA) already, which seamed strange that I had to change from Standard to US English since that was the default language.
But I tried changing the Character Set from “Unicode (UTF-8)” to “System” and it is now importing the text in the .csv files into numbers (Which I wanted) rather than them all being Text.
Thanks @mikekaganski for getting me to a solution.

@erAck Your solution may have worked, but the files I am opening rarely have the same format, so I think I would be changing the macro/filter options all the time. Thankfully changing the character set from UTP-8 to system solved the problem. Thanks for the replay and help.

This only means, that your unknown version of LibreOffice is older than 7.4, where the said dialog was fixed in 2022 to use “Locale” term instead of incorrect “Language”:

1 Like

My version in Linux Mint is, but it is the newest that is in the repositories. But changing the Character Set to System only worked on one computer, not my other computers.

Mint is based on Ubuntu and Ubuntu only do “minor” updates on released versions. For newer versions you can either change to a newer Mint, if it is based on a newer Ubuntu or check to use a ppa. But this is unrelated to your problem with csv-import.