Changing page style on individual page changes other pages

OS: Manjaro 21.2.6

Version: 7.2.6.2 / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-US (en_US.utf8); UI: en-US
7.2.6-1

The document is in .odt format.

When I try to change a page style on an individual page, it changes the style for almost all pages following, and some preceding. I’m working with a document that’s about 120 pages long.

I’m using these directions:

  1. Click in the page that you want to apply the page style to.
  2. Do one of the following:
  • Choose View - Styles, and then click the Page Style icon.Double-click a name in the list.
  • Right-click the page style displayed in the [Status Bar](Welcome to the LibreOffice Writer Help uses page styles to specify the layout,View - Styles. Click the Page Styles icon.). Select another page style.

I’m right-clicking on the style in the status bar to change the style.

I started working on the doc last week. Everything was working fine. I’ve made a few backups by copying and then renaming the file, appending ‘_x’ to it (where ‘x’ is a number).

I tried to change a page style on an earlier version of the document and it worked fine. But the newest version seems to have some sort of bug. I’ve been trying for over two hours but after I found that the problem can’t be reproduced on an earlier version of my document, I figured it’s time to give up and ask here.

I can’t say exactly how to reproduce the problem. I was doing some general editing on the document (it’s a book)… I moved some pages around, changed the formatting on some of the text in different chapters, made a few minor edits, added some comments (first time for this document) Then suddenly I noticed some page settings weren’t as they had been. I had page mirroring enabled but that reverted back to the default. I had headers that showed the page number, book title, and author name, with a top and bottom border… that was gone as well.

I then reviewed the page style info, the custom styles, and tried getting everything back the way it was. But I’m stuck just trying to insert blank pages, because they have the style of the book body with the headers. When I try to set the style for them to the default, almost every other page changes along with it.

I have absolutely no idea when the page styles changed.

Can anyone suggest how to fix this?

I think it’s fixed now. I saw that there was a lot of blank lines and full sentences in the heading section of the navigation. I found that in the style used for the text of most of the document, the outline was set to “heading 1”.

I have no idea how that happened or got changed. I have never edited that setting before on any styles and didn’t even know it existed.

If you have Heading 1 applied to most of your text, this is likely to mess up text flow. This can happen when you apply heading style correctly, then reformat to “plain text” by manual formatting.

If you experience text reflowing problems with your document (paragraphs jumping around), do not hesitate to post a new question.

1 Like

That help page section you quoted is a little misleading.

Rather, see the bottom section on that page, To Apply a Page Style to a New Page.

Background

Page styles in Writer are inherited from previous page.
There is one way to break this inheritance:
Insert a manual page break with new page style specified.

In the Open Document Format, the manual page break is a “special case” of a paragraph break. This means that you cannot have a manual page break in the middle of a paragraph. The Next style setting is what you would use for that.

There are multiple paths to insert a manual page break, but the one outlined on the help page is perhaps the most “intuitive” procedure. Regardless of which one you use, you need to set the break to use a particular page style.
This setting will be part of the paragraph properties for the first paragraph of the new page. You can use Format - Paragraph settings, and also paragraph styles, to adjust this.

To revert to original page style, you need to go through the moves once again as explained in the help section mentioned. See also the box above, about Next style settings.

This may seem a little cumbersome and backwards at first, but it does provide for more consistent page layout across large documents. You will get used to it, and in time, learn to appreciate it.

3 Likes

Writer is based on styles which contain formatting directives for the object on which they apply.

Most known styles are those for paragraph or character “objects” because the concept is shared by almost all document processing applications.

A paragraph is any text delimited by paragraph breaks, i.e. Enter.

Character styles are more “dynamic” in that there is no explicit boundary mark. You just apply a style to a selection.

Writer also offers page styles. The difficult point to understand is pages do not exist per se. They are only a consequently of text flow and formatting. They are allocated on demand to accommodate text size. A sequence of pages shares the same style. Assigning a new style will be effective on the whole sequence.

So how is such a sequence bounded?

You must explicitly insert special page breaks with Insert>More Breaks>Manual Break which will allow you to designate a specific page style to apply after the break. Note that this does not mean you can’t change the page style afterwards with a double-click on a page style name. This manual operation is required to create the explicit boundary. The sequence extends from one boundary to the next.

The common Ctrl+Enter only inserts a page break without creating a page style boundary.

You “structure” (or organise) your document into homogeneous sequences with these special explicit page breaks.

2 Likes

Thanks for all the info. I suspect that at least some of my problems were because it’s been 8 years since I’d last modified the document (book) I was working on. I’m guessing Libreoffice had to convert some of the old formatting ways to the new ones and from a dev perspective, with such a wide gap in time, LO wasn’t designed to perfectly migrate formatting in cases such as mine. And probably I had originally created it with OpenOffice. I don’t really remember 8 years ago that well.