Chapter Number as Text (One, Two), but Footer as Numeric

Is there any way to do this?

I know how to use Paragraph and List Styles. I’d like to have my chapters like this:

Chapter One
My First Chapter

I’ve accomplished this with a Paragraph Style for the Chapter Heading, and a List Style for the “Chapter One” part. Instead of “1,2,3…” I pick “One, Two Three…” as the Number format in the List Style. It works fine.

But in the Footer, I would like it to read:

  1. My First Chapter

When I insert the “Chapter Number” field into the Footer, there is no chance to reformat it as “1, 2, 3…” It always comes in as text numbering “One, Two, Three…”

Maybe there is some way around this with Functions or Variables? I don’t fully understand how to use those.

In the past, what I have done is to create the “Chapter One” as plain text, and then below that put in my Chapter Title using “1, 2, 3” as the chapter numbering format, with the caveat of using a Character Style to format the number as white, so it is essentially invisible on a white page. Then I can insert the Chapter Number into the footer, and it comes in as black text. That works, but it is a bit of a kludge as I have invisible white text, which would still show up if someone copy/pasted the text into a text editor.

Any other thoughts?

To the best of my knowledge, using white characters on white background is the only way to achieve your goal. Even Hidden font effect does not work for an unknown reason.

However, you can diminish the nuisance by modifying Heading n paragraph style bu setting is vertical spacing to 0, font size to 2pt (the absolute minimum) and of course font color to background colour. This way the real heading (from Writer point of view) will occupy minimal space.

Unfortunately, nothing can be done against copy’n’paste in an external program. After all, your headings are not confidential since you duplicate them to change the numbering format.