Chapters not starting on right page despite correct (?) styles

Hi, I am writing a (Master) document made up of chapters. I am using Heading1 as style for my chapters. In settings of Heading1 I have the following:

image description

ChapterStart page style has the following:

These setting seem to be completely ignored: chapters start on pages formatted as left (and margins seem inverted relative to what I set in the page style), and no empty page is inserted before the chapter title to make them start on the right pages.


Do I need to do something else to make this work? Is this a bug?

I have found a lot of answers online how to do this, and thought I followed them when I set up my styles. Thank you.

I am using LO on Ubuntu 16.04.

Test file here:

Note: in this simple test case the page is correctly displayed on the tight side, but there is no empty page just before

The styles used in the final, combined document are those in the master document, not those in the subdocuments. Check the styles in the master.

I am showing all this info about the master document, sorry if this wasn’t clear

Of note, this doesn’t work in a regular document either - the page style is not applied, I need to manually activate the ChapterStart page style for the first page - and then an empty page is still not added. If I use a document starting with a forced ChapterStart page style on the first page in the master document, it is displayed on the right page, but without an empty page before.

@Phlya can you upload a sample document? I’ve never had problems with that feature.

Please see attachment to the original post, and the note before.

@Phlya I can see the automated blank page before chapter 1 in your sample document. Notice that automated blank pages are not displayed during editing, but they are there: just go to the print preview and select the “book view” setting.

Thank you! This helps, but see comment to the other answer.

Everything is OK. It’s only a matter of display. Click on “Book View” near the zoom slider.

The other view modes (single page and multiple-page) are parsimonious with screen real estate. They don’t display internally added pages.

Thank you! This is true, but seems to only work for non-master documents, or if I do the styling in the source files for the master document. So I think the problem is with interaction between Master Document and application of page styles - they are not applied properly. If I export the file to .odt and manually set ChapterStart page styles, it works as expected (although absence of blank pages in regular view is confusing)

There is a lot of literature on style interaction between master and slave documents. As noted,by @RGB-es, master and slaves are independent documents when typing, i.e. their local styles apply. When you assemble the final document in the master (printing time), only styles in the master apply.

The best way to avoid discrepancies is to base master and slaves on the same template and never change any style in documents. Do this only in the template, then update all documents.

I used to split my documents through master and chapter slaves. But PCs are now big and powerful enough to spare this inconvenience. I write manuals in the 250-300 pages range and performance/reactivity is pretty good. So, I now keep a single file.