Character Style set to "None" for List Style does not stick between saves. Is this a bug?

Steps to reproduce:

  1. Create a numbered list and add some text.
  2. Set a list style from the syles sidebar, say “Numbering 123”
  3. Right click on the style, choose “Modify”, navigate to the “Customise” tab and setcCharacter style to “None” for any level.
  4. Save the document.

Observed Behaviour:
On repening the aforesaid saved document, the character style for that particular level will change to the defaul character style for that list style in this case “Numbering Symbols”.

Expected Behaviour:
On repening the aforesaid saved document, the character style for that particular level should remain “None” as set while saving the document.

Version Information:
Version: (x64) / LibreOffice Community
Build ID: a69ca51ded25f3eefd52d7bf9a5fad8c90b87951
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: en-IN (en_IN); UI: en-GB
Calc: CL

According to the screenshot, you created your list with Format>Bullets & Numbering.

This command is offered as a poor man’s compatibility substitute for M$ Word routine. In Word, list numbering concept is not rigorously defined (i.e. not based on strong abstract principles). The command is also offered for quick’n’dirty access to customizing list numbers because defining a paragraph style for auto-numbered list items is probably the most difficult exercise in Writer. You need to combine two style categories to succeed; a paragraph style to globally format the item and a list style to characterize the numbering properties.

The command is a direct formatting directive. In a sense it is equivalent to Ctrl+B to embolden characters. You don’t expect this setting to be enabled from start when you reopen a document if you left it while you were typing bold (this does not mean that what you already typed as bold will be shown as non-bold; what was bold remains bold).

The case of list numbering is a bit more complex. Being a direct formatting command, it can be applied to all numbered items but it must not change what is already formatted. All the more, you may have independent lists, i.e. a formatting change on one must not cause a change on the other(s).

The only way to handle this is not to save the settings of Tools>Bullets & Numbering.

The consistent fix to this situation is not in tweaking LO Writer configuration but in adopting a composing procedure where you use strictly, consistently and rigorously styles and forbid all forms of direct formatting.

This can’t be done in 5 minutes. You must first learn what styles are and what you can expect from them. Contrary to Word which offers only paragraph styles, Writer also provides character, page, frame and list styles. All of them should be considered to achieve “professional” writing and high-quality formatting. For an introduction, read the Writer Guide. This is no tutorial, therefore you have a lot of personal work to do to grasp a global picture and see how you can use the various style categories. You need also to practice on example cases before diving into the real job.

I recommend, once you see where you want to go, you create a template file storing all your customisations of built-in styles and your addition user styles, so that you don’t need to recreate again and again your styles in new documents. This is a way to give all your documents the same look. And also the look is updatable automatically (provided you have no direct formatting) when the template changes.

Thank you for taking the time to explain why this behaviour exists the way it does, I was mildly infuriated by it when I accidentally sent out a document with incorrect formatting because of this unexpected behaviour.

This advice works and has helped me solve the problem; I created a new character style named “Sub-lists” to achieve the equivalent look of “None” for the lower levels in the list and have managed to achieve the formatting I desired which is consistent across saves.

I had a look at the Writer Guide; I am pleasantly surprised to find it to be so comprehensive and will surely ask the newbies in our team to give it a read. (Everyone is still salty about our transition from M$ Word to LibreOffice Writer.)

I have taken your recommendation of creating a template file; I did not know that it is used to save styles. It will save us a lot of headache of having to create copies of our old documents to use as a starting point for the new ones.


Templates not only save styles. This is of course the primary goal, but it is much broader in Writer.

You can also record initial contents. Thus you can have a template for your business letters, prefilled with logo, coordinates, object paragraph and formal salutation at bottom; a template for your technical documentation; a template for your commercial target; …

The difference between initial contents and styles is initial contents doesn’t upgrade when it is changed in the template because it would otherwise erase real contents in the documents.

The only drawback I see in such a collection of templates with initial contents is there is no notion of “master templates” on which “specific templates” could be based. This means you have to import the styles in the “specific templates” when the graphical charter changes.

PS: I might not have understood your purpose. Character style None is list styles means that the numbering receives no additional character styles. In other words, the number is formatted the same as item text. In case you want none of the attributes you have set in the paragraph style (such as italic or bold), you must effectively create a dedicated character style where the conflicting attributes are forcibly disabled. And this is tricky because in any new style, attributes are initially “transparent”. To have them “not set”, you must set them then unset them. Attributes are tri-state but the UI can only render two states!

(edit only changed formatting and fixed misspellings)

1 Like