Characters turned into question marks

Hi, I’ve noticed that this issue has come up before but none of the answers/solutions have worked for me.
I’m working on the latest version of LO - 5.3.4., Win x86. I created a Writer document, the text is in Bulgarian, therefore Cyrillic alphabet. Saved and closed it, only to find that the file only opens up as question marks.
I then tried to fix the problem by changing the character encoding post factum to Unicode 8 (it was Western something or other but unfortunately I didn’t notice which before switching it).
How can the document be recovered?
Interestingly enough, when I click on the desktop icon for LO, it shows a preview of recent files and in the preview the article looks fine, as it should, no ?'s.
I’d upload the file but I need some points to do that, apparently…
Thank you in advance.

Does it happen after changing character encoding to Unicode 8 also, or now everything work fine for new documents? In what character set is your keyboard system wide (Bulgarian, English…)? Did you had such problems before, and if didn’t, what changed in your system since then? Make a copy of that problematic file, rename it from ‘file.odt’ to ‘’. Extract that zip archive and try to open file from it with text editor - do you get question marks or normal text?

Did you save to ODT or to another format? With ODT, you can’t select any encoding, it is always UTF-8. If the preview looks fine, perhaps, you only need to change the font.

I just experienced the same behavior on latest libre office 5.4.2 windows x86_64 running on windows 10.

I typed a document in Cyrillic (Macedonian). While typing everything seemed OK. Saved it as .docx. and reopened for editing to find the whole text (but not numbers) turned into question marks “???”.

I also noticed that this has happened to another document that I have in a .txt format.

Documents in .odt seem to be unaffected.

I assume by question mark you mean the �. This is the Unicode U+FFFD REPLACEMENT CHARACTER. You should not normally see this on a straight LibO system English or Bulgarian.

Did you type the document using LibO Writer? Was the correct character being shown on the screen, then you saved the document to a .odt file? You then had this problem when you loaded the same file on the same system. LibO uses Unicode which includes Cyrillic (U+0400 to U+04FF). You do not define the character encoding within LibO.

I would normally expect to see the � character when you entered the text on another system and imported or copied it across to LibO writer. This usually indicates the problem lies in that area. With more information we may be able to help you further, especially the character being displayed if it is not a �.

So the problem is that characters are being replaced with standard Question marks ??? and you are using a Windows system. This is probably not a LibreOffice problem. To check, save your document as a normal ,odt file which uses the international Unicode character set, just like the default for the Internet. You should then be able to load the file without problems.

Unicode provides support for Bulgarian as which includes Cyrillic (U+0400 to U+04FF). You do not define the character encoding within LibO. If your Windows system is set to a Microsoft setting specific for Bulgarian such as Windows-1251 or ISO-8859-5 rather than Unicode, these settings do not understand Unicode and only use 8 bits. When you load the document it will not understand the document. You need to tell your system to use Unicode.

Of course you could, if possible, install LibreOffice on your other system. LibO is free, and will bypass this character set problem, and work with any language. I hope this will clarify why you have the ???.

Hi, by question mark I mean actual question mark, not the one you’ve copied here (black diamond), one you would see if you were typing a text.
I wrote the document with LibO Writer, saved as a Word doc, so it would be compatible with my other computer and sent it to myself via email. Tried to open it from there with Word - question marks. Went back to my original computer, saved it as odt as well, tried switching fonts - none of these techniques work.

After switching to Uni 8, it works fine but I want to save my original document.

And why can’t I upload it here when others have been able to?

Click on Edit and then press Ctrl+F or click on the staple icon to upload an attachment file. If you can’t do that (i. e. you don’t see a file upload dialog), then your karma is not enough. Use a file sharing service such as Google Drive, Yandex Disk, etc.

re: “why can’t I upload it here when others have been able to?”

You have not enough karma. To make things worse, for unclear reason, you created your question as “community wiki”, which does not allow others to upvote your question (or at least your “answer”, which you made wiki, too) and so we cannot increase your karma to enable you to attach directly here.

Why don’t we have a label in BIG RED near the “wiki” checkbox telling “Do NOT check it unless you understand what you are doing!”?

Next note. Please don’t “answer” your (or other’s) question unless your message actually answers the question. Otherwise, please use comments to add information/clarifications to questions.

Finally. MS Word 97-2003 *.DOC should be perfectly able to hold multi-language documents. If you found out that it’s not so - please file a bug report to our bugzilla.

But can’t it be that your mailer had ruined your DOC (because of some misconfiguration) because it transferred it not as a binary data, but as plain text, and so you have a corruption on transfer? Could you please check that?