Charts in XLSX documents generated with EPPLUS don't have colors in Calc

I’m using the EPPLUS library to generate spreadsheets from C# applications and I’m trying to draw a simple pie chart on the worksheet. But when I open the file - all the colors/borders/any graphics is entirely missing from the chart, there are only numbers and labels floating over the empty area.

If I open the same document in other programs - it works just fine.

But if I save it from the Calc and then open in Excel - the graphics is missing there as well and the chart has no set style, the graphics returns if I select any style in Excel.
I tried updating Calc from v6 to v7 to no avail. Tried completely uninstalling it and removing the residual files, then installing it back after the reboot. Nothing changed, Calc still doesn’t want to draw those charts correctly.
At this point I’m out of ideas, maybe you have any?

Further testing reveals that the problem lies within the EPPlus library of any versions. XLSX files created with that library are missing the necessary styles and make the charts look broken when open in LibreOffice. However if the file was is to be created in a different library, or just a regular XLSX file is to be used a template to be filled - everything works fine.
Is there some kind of property in the document that LibreOffice depends on for drawing the charts? Maybe it can default to some style if the property is missing?

It doesn’t matter if the document is generated using this library or that. What matters is if the document a valid OOXML. Please check if the files are valid XML (you may use Open XML SDK Productivity Tool for MS Office), and if the file is valid, file a bug report with attached sample and screenshots from Calc and Excel.

But if the file is not a valid OOXML, then it’s a bug in the generator, and it just happens to work relying on specific treatment of invalid data by Excel, and that is something to inform the library developers.

Thank you, I did just that, but unfortunately I’m not sure what to make of the results…
I had one file generated and filled with EPPlus (tst.xlsx) and another generated with ZetExcel but filled identically with EPPlus (tstZE.xlsx)
The tool marked both files as valid

However comparing both of them together clearly shows some difference in their internal relationships structure.
The valid file also has a /docProps/core.xml component. But still they are both “valid”?

Here’s both files opened side by side in LibreOffice Calc:

and Microsoft Excel:

You think that’s a bug with Calc not interpreting some missing data or the library for not generating the necessary component? Does the validation account for that?

A good validator would catch some missing data required for some existing data. I can’t know for sure how well the validator is made, but at the first approximation, we can assume it reports correct things. So just go ahead and file the bug report. Thank you!