Charts with bar or column type disappearing

Hi, after last update(Version:, my existing column charts disappeared, at that time I tried to create a new one so I noticed that both, column and bar, will disappear after I finish the dialog, but if I choose other type it works, so as I needed the chart information that time, I just changed it to a working one, but for some data I really need the column type.(That was just after the update)

Today, when I was just using the spreadsheet, when I clicked in a cell, it showed up those eight squares typically used for resizing charts or images, but without anything inside, I double clicked on It and an old chart(that disappeared at update) showed up! but as last time, when I finish clicking anywhere on the screen it disappears again. I found other charts clicking randomly and changed the type so they stayed.

Any idea of what is happening? so far this is the only problem I noticed.

Note: I thought it was an arrangement problem so I tried to bring it to front, forward one and so… It didn’t work

I’m having the same problem. I have found it has something to do with the Categories selected in the chart. If I pick a column with just numbers for the x-axis categories then the chart stays when I click out of edit mode. If I pick the column of dates that I need, then the chart disappears when I click out of edit.

I’ve tried selecting the dates and then formatting the x-axis numbers to various things, but it always disappears. The chart stays, with all the data columns selected if I just blank out the Categories column.

Also the legend is displaying the series in reverse order.

EDIT: The best solution I have come up with so far is to source the Categories from a new column that has converted the original dates to text, using the following formula:


That labels the x-axis and the chart stays visible when I click out of edit mode.

Why do you think that you have to write your question here as an answer, if it is not a response to the initial question of the OP?

I was responding because I have the same issue, have found a couple of potential things that might be causing it, and have now got stuck trying to resolve it.

In my experience this has been an appropriate way to further the conversation on other message boards, but I apologize if that is not the case here. If it’s only concrete answers that are allowed here, I did not realize. Sorry.

You have now found the right way, use comments.

Oh I see! I did an answer instead of a comment, although I’ve no idea how. Either way, sorry! Nooby dooby time.