Check box control not allowing changes

I have a form that contains a couple check boxes that will not allow any changes to be made to their associated controls for the active record. They are enabled (They are initially disabled, but I launch a macro that enables them and then throws a msgbox displaying their enabled status. This is done for a whole series of checkboxes in the form, and virtually all of them work properly after the macro enables them.) Is there some setting I might be overlooking that may be set improperly that might be causing this? The backend is MySQL 5.7, and I am able to toggle them manually with a SQL Update command. (After I toggle them, it is reflected in the checkbox control on the form the next time I go to that record, but I still can’t toggle them from the form.)

Version: (x64)
Build ID: 144abb84a525d8e30c9dbbefa69cbbf2d8d4ae3b
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

Note: I even tried deleting one of the offending checkboxes and copying and pasting one that was behaving correctly, pointing it to the correct field, but still no success.

Can you upload some sample file here?

Thanks for the response! I can add my .odb file, but the backend is MySQL, which I can’t really share.
Edit: I’m replacing my upload with a newer version where the “Order Reviewed By” listbox is enabled, since that is the one that is supposed to launch the macro that enables the checkbox.
Metrology 2.5.9.odb (348.1 KB)

Sorry, should have mentioned, the form “Reviewing Workorders” is where the offending checkbox is, and the checkbox “RevSpecialInstructions” is the main problem.

I stand corrected. None of the checkboxes are working. I can toggle most of them to “true”, but when I close the form (and select “yes” when asked whether to save the data changes), the fields are still set to 0 in the database.

Your sample is of little help as it has a connection to MySQL. Without being able to connect, cannot get at tables or forms. Did see most check boxes were not tied to a data field but at least one was. That check box also was overlapped by the label to its’ right. Those items are issues to be corrected.

Thanks! Exactly what I needed. I would never have guessed the overlapping label would prevent toggling the checkbox, but apparently, it was.