Choose your poison: garbled text, no middle mouse button scrolling, or unable to open remote files

I am working on Xubuntu 16.04.2, running xfce 4.12 and LibreOffice was in 5.1.4.

With some system upgrade towards the end of 2016 / beginning of 2017 the problem with garbled text in libreoffice calc started. That is, if you would edit a cell, it was really hard to read while typing. I found out that this could be solved by uninstalling libreoffice-gtk (the gtk 2 version, I suppose) and install libreoffice-gtk3 instead.

This, however, led to non functioning middle mouse button scrolling (using the trackpoint on a Dell Latitude and the middle mouse button under the space bar). So I uninstalled both, libreoffice-gtk and libreoffice-gtk3. The result was quite ugly (theme wise), but I seemed to be able to work productively again.

Until it turned out that I no longer can open remote files (e.g. from nfs or sshfs). If at all, I got the message “General input/output error …”. This was due to a missing libreoffice-gnome (which might have been uninstalled while uninstalling the libreoffice-gtk). However, re-installing libreoffice-gnome also pulled in libreoffice-gtk as a dependency and I was back at the start.

Eventually I installed libreoffice from ppa (as described in, thinking that this might solve my problems (as there were also indications in several forums on the net). However, with libreoffice-gtk3 installed, opening files was painfully slow (we are talking minutes to open a ~100kB odt file) so this had to go. While then using libreoffice-gtk again, I first thought my problems were solved, but the garbled text problem still persists.

I am writing this to share my experience rather than asking a particular question. However, it would be nice if someone can reproduce this problem or even indicate a solution for Xubuntu 16.04.2 + XFCE 4.12 + libreoffice + capability to edit cells (with unobscured font/content), to open files from remote network places, to scroll through documents and to open files in a time appropriate to file size and local storage on a SSD.


Have similar set up to what you mention. Xubuntu 16.04.2, kernel 4.4.0-59-generic, Xfce 4.12, LO v5.2.3.3 currently (switch between many versions for testing - 4.4.x thru 5.3.x & dev), no gtk or gtk3, no LO gnome, older desktop hardware Quad core, 4gb, mechanical disk old video card, generic mouse (no scrolling problems).

Some minor differences - no SSD, only an occasional remote network access (testing purposes), get all LO versions from LibreOffice (too many problems with distro versions).

No problems with LO Calc, Writer or Base (all frequently used). All open relatively quickly with the exception of one 600k+ writer doc - about 5 sec.

Have had occasional blip with a bad kernel or two but easily remedied. Used as main system for quite some time until Mint 18 Cinnamon (some options I prefer). Still use Xubuntu quite often (actually currently) because of different DB software installed. No complaints at all.