Clean installation of Libreoffice crashes on startup

I recently upgraded my Slackware64-Current Linux distribution (12/22/2021 version) on my desktop. The new system uses the 5.15.10 version of the kernel. It also included upgrading libreoffice to version 7.2.4. Libreoffice works just fine on my desktop machine, but when I did the exact same upgrade on my new laptop and tried to start libreoffice, it shows the splash screen then crashes. Even when started from the command line, there isn’t any error information. I can get libreoffice to run if I start it in safe mode, but changing the options shown there doesn’t seem to make any difference. This leads to three questions:

  1. How to get libreoffice running in regular mode on my laptop?
  2. Why isn’t/wasn’t it running on the laptop?
  3. Why does the exact same setup work on my desktop but not on my laptop?

Any suggestions is appreciated

Can you open LibreOffice in safe mode? According to FAQ, launch it from the command line with libreoffice --safe-mode then continue in safe mode

If it opens in safe mode, click Tools > Options > View and untick Use Skia for all rendering, OK out. With a bit of luck you can exit LibreOffice and start in normal mode without problem. This would be a graphics card issue.

If you still have an issue then try backing up your user profile and then resetting it, see LibreOffice user profile - The Document Foundation Wiki . You can copy back useful folders such as templates, autocorrect, wordbook, etc. afterwards.

I have been able to open LibreOffice in safe mode from the start. I followed your directions to get to the View option. There aren’t any entries labeled Use Skia for all rendering. the tickable options are

  • Use hardware acceleration
  • Use anti-aliasing
  • Show preview of fonts
  • Screen font antialiasing

I tried unclicking Use hardware acceleration but that didn’t change anything. The interesting thing is that when I restarted LibreOffice in safe mode and went back to the View option, Use hardware acceleration was again ticked.

When I start in safe mode I am given a number of options before going into LibreOffice directly. One of those options has been to Reset entire user profile. I have tried this a number of times without any apparent effect. Another interesting thing is that I don’t see any apparent change in .config/libreoffice/4/user when I try this. I also tried deleting the user folder and restarting LibreOffice normally. It crashed again.

Are there other things I can try?

By the way, is there a way to start LibreOffice so that I get a verbose listing of what it is trying? While I don’t expect it to be a missing file, perhaps I will see something that will make debugging easier.

It still sounds like a graphics card issue. A quick internet search found this slightly older thread which might be relevant,

A number of graphics cards were listed in LibreOffice denylist for OpenGL but I am not sure there is a denylist yet for Skia/Vulcan. Safe Mode disables hardware acceleration as well as providing a new, temporary user profile.

I am over my head with Linux, especially since my Linux computer died last year.

This is depressing. I’m having other graphics card issues (no sound - apparently that goes through the video card as well) so I went back to the NVidia site to get a driver that is listed specifically for my card type. I downloaded the software and used the SlackBuild scripts to install them. It didn’t change anything. LibreOffice crashes and no audio. I’m going to try and post something for help with regards to the graphics card on the Razer website. I’ll also check out the link that you recommended. Any additional help is appreciated!